Opened 10 years ago

Closed 10 years ago

#14264 closed defect (fixed)

problems of "mblAndroidWorkaround"

Reported by: zhangzxm Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.0
Keywords: mblAndroidWorkaround Cc: Atsushi Ono
Blocked By: Blocking:

Description

When set "mblAndroidWorkaround=true", it will cause some css3 effect doesn't work on android device in some case. In the attached case, the "puff" box cannot be restored on end in some case.

Attachments (2)

test1.html (1.0 KB) - added by zhangzxm 10 years ago.
css3.css (691 bytes) - added by zhangzxm 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by zhangzxm

Attachment: test1.html added

Changed 10 years ago by zhangzxm

Attachment: css3.css added

comment:1 Changed 10 years ago by bill

Component: DojoxDojoX Mobile
Owner: changed from Adam Peller to ykami

comment:2 Changed 10 years ago by ykami

Cc: Atsushi Ono added

comment:3 Changed 10 years ago by bill

Milestone: tbd

comment:4 Changed 10 years ago by Atsushi Ono

Thanks for reporting the issue. As you reported, this issue is caused by the workaround code for Android screen flicker issue (#12732), and can be avoided by adding "mblAndroidWorkaround:false" to djConfig in 1.7.

In 1.8, we have reconsidered the workaround code in #14632, and finally found a new workaround which has almost no side effects. Therefore this issue has been indirectly fixed in 1.8 now.

comment:5 Changed 10 years ago by ykami

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

Closing the ticket because it was indirectly fixed with #14632.

Note: See TracTickets for help on using tickets.