Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14263 closed enhancement (fixed)

Um Alqura Calendar needs to be supported

Reported by: HKatory Owned by: HKatory
Priority: high Milestone: 1.9
Component: Dojox Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

Um Alqura Calendar is a subset of Hijri ( Islamic ) Calendar with a special calculation used as the official calculation for KSA as Country Official calendar system.

Attachments (5)

umalqura.patch (58.4 KB) - added by Adam Peller 8 years ago.
implementation from Hossam Katory (IBM, CCLA)
14263.patch (197.2 KB) - added by cjolif 7 years ago.
Updated patch from Hossam Katory (IBM, CCLA).
umalqura.2.patch (223.6 KB) - added by cjolif 7 years ago.
Updated & cleanup patch from Hossam Katory (IBM, CCLA)
UmAlqura+fixes.patch (249.7 KB) - added by cjolif 7 years ago.
Updated patch from Hossam Katory (IBM, CCLA) with test fixes
dojox.rar (22.1 KB) - added by Mohammad Masoud 7 years ago.
screenshot and HTML code

Download all attachments as: .zip

Change History (20)

comment:1 Changed 8 years ago by Adam Peller

Component: GeneralDojox
Milestone: 1.7.11.8
Owner: set to Adam Peller

Changed 8 years ago by Adam Peller

Attachment: umalqura.patch added

implementation from Hossam Katory (IBM, CCLA)

comment:2 Changed 8 years ago by Chris Mitchell

all new contributions should be contributed in AMD 1.7 format with minimal base dependencies.

comment:3 Changed 8 years ago by Adam Peller

Owner: changed from Adam Peller to HKatory
Status: newpending

@Hossam: we'll need these converted over to AMD to match the other modules

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 7 years ago by khouly

Reopening to submit code with changes requested and add extra testing coverage

comment:6 Changed 7 years ago by Adam Peller

Milestone: 1.82.0
Resolution: invalid
Status: closedreopened

unfortnuately, we're past code freeze for 1.8

Changed 7 years ago by cjolif

Attachment: 14263.patch added

Updated patch from Hossam Katory (IBM, CCLA).

Changed 7 years ago by cjolif

Attachment: umalqura.2.patch added

Updated & cleanup patch from Hossam Katory (IBM, CCLA)

Changed 7 years ago by cjolif

Attachment: UmAlqura+fixes.patch added

Updated patch from Hossam Katory (IBM, CCLA) with test fixes

comment:7 Changed 7 years ago by cjolif

Milestone: 2.01.9

comment:8 Changed 7 years ago by cjolif

Resolution: fixed
Status: reopenedclosed

In [29971]:

fixes #14263. Um Alqura Calendar implementation. Thanks Hossam Katory (IBM, CCLA).

comment:9 Changed 7 years ago by cjolif

In [29973]:

refs ##14263. Revert previous wrong commit.

comment:10 Changed 7 years ago by cjolif

In [29975]:

fixes #14263. Um Alqura Calendar implementation. Thanks Hossam Katory (IBM, CCLA).

comment:11 Changed 7 years ago by cjolif

In [29976]:

refs #14263. Um Alqura Calendar implementation. Thanks Hossam Katory (IBM, CCLA). !strict.

comment:12 Changed 7 years ago by bill

The formatting of the doc comments in this file is all wrong. You need to follow the syntax explained in http://livedocs.dojotoolkit.org/developer/markup.

comment:13 Changed 7 years ago by bill

In [30103]:

fix api doc comment format and spelling, refs #14263

comment:14 Changed 7 years ago by Adam Peller

Hossam, please write up an entry on the wiki to match http://livedocs.dojotoolkit.org/dojox/date/islamic when you have a chance

Changed 7 years ago by Mohammad Masoud

Attachment: dojox.rar added

screenshot and HTML code

comment:15 Changed 7 years ago by Mohammad Masoud

hi, i followed the help submitted by hosam for umalqura calendar and its was not working the problem is that js files are not there when they are called from source , see attached files for clarifications.

Note: See TracTickets for help on using tickets.