Opened 7 years ago

Closed 4 years ago

#14251 closed task (fixed)

use CSS transitions instead of javascript animations

Reported by: bill Owned by:
Priority: high Milestone: 2.0
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Use CSS transitions in dijit, rather than javascript animations, degrading to no animations (ie, instant change of display) on browsers that don't support CSS transitions.

Unfortunately IE9 doesn't support CSS transitions so maybe the time isn't ripe for this change. IE10 apparently supports them.

Attachments (1)

Tree_CSS_animations.patch (6.8 KB) - added by bill 7 years ago.
Prototype of using CSS transitions for Tree (TreeNode expand/collapse). Apply against [27014].

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by bill

Attachment: Tree_CSS_animations.patch added

Prototype of using CSS transitions for Tree (TreeNode expand/collapse). Apply against [27014].

comment:1 Changed 7 years ago by bill

Description: modified (diff)
Summary: use CSS transitions instead of fxuse CSS transitions instead of javascript animations

comment:2 Changed 6 years ago by bill

#13146 is a duplicate of this ticket.

comment:3 Changed 4 years ago by bill

Resolution: fixed
Status: newclosed
Type: defecttask

Guess we should close this as fixed since https://github.com/ibm-js/deliteful is using CSS animations when possible.

Note: See TracTickets for help on using tickets.