Opened 8 years ago

Closed 7 years ago

#14250 closed defect (invalid)

IconItem top size is negative

Reported by: Eric Wang Owned by: Eric Wang
Priority: high Milestone: tbd
Component: DojoX Mobile Version: 1.7.0
Keywords: IconItem Cc: Atsushi Ono
Blocked By: Blocking:

Description

In IconItem? _setIconAttr method, there's no check code for p.offsetHeight. p.offsetHeight maybe 0 in some situation and the top size will be negative after calculation. So we get the wrong IconItem? position.

see attachment.

Attachments (1)

IconItem top position is negative.doc (83.5 KB) - added by Eric Wang 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Eric Wang

comment:1 Changed 8 years ago by ykami

Cc: Atsushi Ono added

comment:2 Changed 8 years ago by Atsushi Ono

I understand your point, but I could not reproduce the issue with our IconItem test cases. Could you please give us a minimum test case to reproduce the issue if possible?

comment:3 Changed 7 years ago by bill

Milestone: tbd

Shouldn't set milestone unless someone has committed to do the work for that milestone.

comment:4 Changed 7 years ago by ykami

Owner: changed from ykami to Eric Wang
Status: newpending

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.