Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1425 closed defect (fixed)

accordion broken?

Reported by: bill Owned by: neil
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

In test_Accordion.html, just click on Pane 1, Pane 2, Pane 3 repeatedly. Pane2 and Pane3 appear empty. Tested on IE6.

Attachments (4)

html.js.BUG_TRAC_1425_716_864_866.patch (2.3 KB) - added by neil 13 years ago.
lfx utilities to correct functionality of wipein/wipeout for accordion widget, intended functionality and the testcase test_wipe.html; patch for $DOJO_ROOT/src/lfx/html.js
TitlePane.js.BUG_TRAC_1425_716_864_866.patch (715 bytes) - added by neil 13 years ago.
Modification to $DOJO_ROOT/src/widget/TitlePane.js to accommodate updated lfx wipein/wipeout.
AccordionPane.js.BUG_TRAC_1425_716_864_866.patch (482 bytes) - added by neil 13 years ago.
Patch for $DOJO_ROOT/src/widget/AccordionPane.js to accommodate updated lfx.
test_wipe.html.BUG_TRAC_1425_716_864_866.patch (500 bytes) - added by neil 13 years ago.
Patch for $DOJO_ROOT/tests/animation/test_wipe.html; to be used with patched lfx to demonstrate intended wipein/wipeout functionality

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by neil

Owner: changed from bill to neil
Status: newassigned

comment:2 Changed 13 years ago by neil

Modifications commited to lfx utilities have introduced characteristics incompatible with Accordion pane and for wipe/in/out features of lfx. Included are patches to correct behavior of lfx and patches to accordion/title pane to correct intended functionality. An updated patch to wipe functionality testcase for lfx is included. In the future it is wise to regression test modifications made to dojo code base prior to committing code.

Patches: AccordionPane?.js.BUG_TRAC_1425_716_864_866.patch, to be applied to $DOJO_ROOT/src/widget/AccordionPane.js, TitlePane?.js.BUG_TRAC_1425_716_864_866.patch, to be applied to $DOJO_ROOT/src/widget/TitlePane.js, html.js.BUG_TRAC_1425_716_864_866.patch, to be applied to $DOJO_ROOT/src/lfx/html.js test_wipe.html.BUG_TRAC_1425_716_864_866.patch, to be applied to $DOJO_ROOT/tests/animation/test_wipe.html

Patches/testcases tested with FF,opera and ie.

Changed 13 years ago by neil

lfx utilities to correct functionality of wipein/wipeout for accordion widget, intended functionality and the testcase test_wipe.html; patch for $DOJO_ROOT/src/lfx/html.js

Changed 13 years ago by neil

Modification to $DOJO_ROOT/src/widget/TitlePane.js to accommodate updated lfx wipein/wipeout.

Changed 13 years ago by neil

Patch for $DOJO_ROOT/src/widget/AccordionPane.js to accommodate updated lfx.

Changed 13 years ago by neil

Patch for $DOJO_ROOT/tests/animation/test_wipe.html; to be used with patched lfx to demonstrate intended wipein/wipeout functionality

comment:3 Changed 13 years ago by bill

This regression was caused by lfx/html.js [5108], which fixed wipeIn/wipeOut for objects w/unspecified height, but broke Accordion (and other stuff too, maybe), because it hides objects by setting visibility:hidden rather than display:none.

This is a similar problem to the fadeIn/fadeOut discussions from a few months ago, where fadeIn/fadeOut would leave the object with display: block, opacity 0, rather than display: none (as I would have expected).

comment:4 Changed 13 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed in [5940] or earlier.

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.