Opened 8 years ago

Closed 7 years ago

#14240 closed defect (fixed)

TooltipDialog and DropDownButton problem in IE

Reported by: ericallhans@… Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

I have a series of tooltip dialogs and dropdown buttons that in essence create a tree like structure to query data.

In firefox:

http://dojo-toolkit.33424.n3.nabble.com/file/n3437836/dojo_ttd.jpg

This works great in chrome and firefox, but in IE, if I select Disease A, then select Disease B, it closes all the tooltip dialogs and dropdown buttons and pushes the last one selected to the top of the screen and covers the Data button:

In IE:

http://dojo-toolkit.33424.n3.nabble.com/file/n3437836/dojo_ttd2.jpg

Attachments (1)

dd.html (5.1 KB) - added by bill 8 years ago.
test case

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by bill

Attachment: dd.html added

test case

comment:1 Changed 8 years ago by bill

Milestone: tbd

comment:2 Changed 7 years ago by bill

Description: modified (diff)
Owner: set to bill
Status: newassigned
Summary: Tooltip dialog and dropdown button problem in IETooltipDialog and DropDownButton problem in IE

Hmm, I couldn't reproduce this against trunk or the 1.6 branch, or even the 1.6.0 tag, using IE9, IE8 and IE6.

Version 0, edited 7 years ago by bill (next)

comment:3 Changed 7 years ago by bill

Milestone: tbd1.7
Resolution: fixed
Status: assignedclosed

Fixed by [25313].

Note: See TracTickets for help on using tickets.