Opened 13 years ago

Closed 12 years ago

#1423 closed defect (fixed)

HTA application failed to load "dojo.widget.LayoutContainer" with error "Internet Explorer cannot open the internet site file://... Operation aborted"

Reported by: thaiha@… Owned by: bill
Priority: high Milestone: 0.9
Component: Dijit Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

I'm trying to use DOJO with my HTA application and I found this error "Internet Explorer cannot open the internet site file://... Operation aborted" when i tried to opened it from my hard disk. The HTML for my HTA is below:


<html> <head>

<hta:application id="oHTA" applicationname="TEST" border="thick" caption="yes" showintaskbar="yes" singleinstance="yes" sysmenu="yes" windowstate="normal"> <script type="text/javascript" src="dojo/dojo.js"></script> <script type="text/javascript">

dojo.require("dojo.widget.*"); dojo.require("dojo.widget.LayoutContainer?");

</script> <title>TEST</title>

</head> <body> TEST </body> </html>


DOJO: 0.3.1 Windows 2000 IE 6.0.2800.1106 SP1

I found out that this error will appear when:

  1. dojo.widget.LayoutContainer? is used
  2. and the element <hta:application> is located above the DOJO Javascript code and it is not written as XML element (<hta:application />)

Change History (5)

comment:1 Changed 13 years ago by guest

Version: 0.20.3

comment:2 Changed 13 years ago by guest

Component: GeneralWidgets
Owner: changed from anonymous to bill

comment:3 Changed 13 years ago by guest

I found the following code (src/html/layout.js, line 105) (which is ran when we require html.layout component)

dojo.style.insertCssText(...);

is the root cause of the problem. Maybe this call changed the document before it's loaded (Google found some comments relating to kind of errors) and IE shows this strange error.

I think a solution is to schedule dojo.style.insertCssText(..) to run sometime after the document is fully loaded.

comment:4 Changed 13 years ago by dylan

Milestone: 0.5

comment:5 Changed 12 years ago by bill

Component: WidgetsDijit
Resolution: fixed
Status: newclosed

ContentPane? in Dijit doesn't do any CSS munging, so this will no longer be an issue.

Note: See TracTickets for help on using tickets.