Opened 8 years ago

Closed 8 years ago

#14225 closed defect (duplicate)

View moveTo SwapView, swapView lose its feature

Reported by: davliu Owned by: ykami
Priority: high Milestone:
Component: DojoX Mobile Version: 1.7.0
Keywords: swapView Cc:
Blocked By: Blocking:

Description

Use the code below to reproduce the issue. the cause is that when view transition to swapview,sawapView domNode lost class "mblSawpView"

<body>

<div dojoType="dojox.mobile.View" height="100%" selected="true">

<div dojoType="dojox.mobile.RoundRect?" style="overflow:hidden">

<li dojoType="dojox.mobile.ListItem?" moveTo="foo">

go

</li>

</div>

</div> <div id="foo" dojoType="dojox.mobile.SwapView?" height="100%">

<div dojoType="dojox.mobile.RoundRect?" style="overflow:hidden">

Hello there 1

</div>

</div>

<div dojoType="dojox.mobile.SwapView?">

<div dojoType="dojox.mobile.ScrollableView?" height="100%">

<div dojoType="dojox.mobile.RoundRect?" style="overflow:hidden">

Hello there 1

</div>

</div>

</div> <div dojoType="dojox.mobile.SwapView?">

<div dojoType="dojox.mobile.ScrollableView?" height="100%">

<div dojoType="dojox.mobile.RoundRect?" style="overflow:hidden">

Hello there 2

</div></div>

</div>

</body>

Change History (1)

comment:1 Changed 8 years ago by ykami

Resolution: duplicate
Status: newclosed

Duplicate of #13414.

Note: See TracTickets for help on using tickets.