Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14204 closed task (fixed)

convert dojo/query/acme to be baseless

Reported by: bill Owned by: bill
Priority: high Milestone: 1.8
Component: Query Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

It has minimal dependencies but is still needlessly referencing the dojo "global".

Change History (4)

comment:1 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

In [26962]:

Convert acme to be baseless, plus spelling and lint fixes. Fixes #14204 !strict.

comment:2 Changed 8 years ago by Kenneth G. Franqueiro

In [27044]:

Remove spurious introduction of a dojo.byId call in acme, refs #14204 !strict

comment:3 Changed 8 years ago by Kenneth G. Franqueiro

In [27045]:

Well, looks like that byId call is necessary. Adding it back using dom.byId. Sorry guys, thanks Bill for keeping me honest. Refs #14204 !strict

comment:4 Changed 8 years ago by bill

For the record, without the dojo.byId() / dom.byId() call, the NodeList-traverse.html regression test fails. The dispatcher function dojo.query(query, "id") works with a string ID but query() in acme.js is a slightly different method. Probably the dispatcher method does the id --> node conversion.

Note: See TracTickets for help on using tickets.