Opened 7 years ago

Closed 6 years ago

#14195 closed defect (wontfix)

dojox.mobile.Heading moveTo not taking into consideration when used in a dojox.app application

Reported by: ebengtso Owned by: Ed Chatelain
Priority: high Milestone: tbd
Component: DojoX App Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

First of all, no transactions are happening if I dont have the module "dojox/app/module/history" (reproduceable in multisceneapp by removing the history module).

Now the issue I report is quite simple to describe, the dojox.mobile.Heading back button is ignoring the moveTo attribute and only performs the transition based on the "history".

Change History (4)

comment:1 Changed 7 years ago by bill

Resolution: wontfix
Status: newclosed

dojox/mobile/app is deprecated in favor of dojox/app, and presumably will be removed in 2.0, so seems like we should mark this as wontfix.

comment:2 Changed 7 years ago by bill

Resolution: wontfix
Status: closedreopened

Oops, this ticket isn't about dojox/mobile/app, it's about dojox/mobile and dojox/app.

comment:3 Changed 6 years ago by cjolif

Component: DojoX MobileDojoX App
Owner: changed from ykami to Ed Chatelain
Status: reopenedassigned

Ed, can you look into this, this looks more for you than dojox/mobile? If that is indeed a dojox/mobile issue please re-assign to edurocher.

comment:4 Changed 6 years ago by Ed Chatelain

Resolution: wontfix
Status: assignedclosed

I was not sure if I should say worksforme or wontfix, because transitions work without the history controller, but we do not do transitions for moveTo we do it for Transitions.

Note: See TracTickets for help on using tickets.