Opened 8 years ago

Closed 8 years ago

#14188 closed defect (invalid)

dijit.findWidgets(): Problems with node.nextSibling in IE9

Reported by: Alexander Kläser Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Under specific circumstances, IE9 would return null with node.nextSibling, although multiple childs were present in the root node. The property children worked fine in this case. This caused dijit.findWidgets() (and thus also _WidgetBase.getChildren()) to return only one element (firstChild worked), although multiple childs are present (and visible on screen).

I'm not sure whether this is a know bug in IE... however, this fix solved our problems.

Attachments (1)

fix_dijit_findWidgets.patch (759 bytes) - added by Alexander Kläser 8 years ago.
patch

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Alexander Kläser

Attachment: fix_dijit_findWidgets.patch added

patch

comment:1 Changed 8 years ago by bill

I can't check in a patch without a test case. Can you give a test case to reproduce this problem?

comment:2 Changed 8 years ago by bill

Resolution: invalid
Status: newclosed

Closing due to lack of test case, and no response to above comment. Note that dijit/tests/registry.html passes fine on IE9.

Please reopen after you have attached a test case.

Note: See TracTickets for help on using tickets.