Opened 8 years ago

Closed 7 years ago

#14186 closed defect (fixed)

mobile listItem callback function can't be called when clicking it to start transition to another view

Reported by: davliu Owned by: ykami
Priority: high Milestone: 1.7.3
Component: DojoX Mobile Version: 1.7.0
Keywords: transition, callback, context Cc: Atsushi Ono
Blocked By: Blocking:

Description

In dojo mobile 1.6.1, if I specify the callback method when creation mobile listItem and make transition to other view by clicking the item, the callback method will be fired, and in the onBeforeTransitionOut stub method of the view, the context, method param will filled with the item node and callback method. However, the same code can not run in dojo 1.7, it just ignore the callback and context is null as well.

I attached the 2 file for comparison, one for 1.6 and another for 1.7. put them to the relevant dojo mobile test folder and check the console.

Attachments (4)

test_transition-connect_1_6_1.html (4.1 KB) - added by davliu 8 years ago.
test_transition-connect_1_7.html (4.1 KB) - added by davliu 8 years ago.
14186.patch (662 bytes) - added by Atsushi Ono 8 years ago.
[patch][ccla] ViewController fix
14186_1.7.3.patch (753 bytes) - added by Atsushi Ono 7 years ago.
[patch][ccla] ViewController fix for 1.7.3

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by davliu

Changed 8 years ago by davliu

Changed 8 years ago by Atsushi Ono

Attachment: 14186.patch added

[patch][ccla] ViewController fix

comment:1 Changed 8 years ago by Atsushi Ono

It seems that ListItem's callback feature has been unexpected omitted when view transition architecture was switched to use ViewController in 1.7. I attached a patch to fix ViewController#onStartTransition to pass the context and callback arguments properly to call View#performTransition.

comment:2 Changed 8 years ago by ykami

Milestone: tbd1.7.1
Status: newassigned

Thank you onoat for the patch. I think your observation is correct.

comment:3 Changed 7 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [27162]:

Fixes #14186 !strict. If a widget that initiated the transition has a callback, pass it to View.performTransition(). This was a regression bug introduced during the view transition refactoring.

comment:4 Changed 7 years ago by ykami

Milestone: 1.7.11.8

comment:5 Changed 7 years ago by Adam Peller

Milestone: 1.81.7.3
Resolution: fixed
Status: closedreopened

since this is a regression, please consider backporting to 1.7.3.

comment:6 Changed 7 years ago by ykami

Cc: Atsushi Ono added

Changed 7 years ago by Atsushi Ono

Attachment: 14186_1.7.3.patch added

[patch][ccla] ViewController fix for 1.7.3

comment:7 Changed 7 years ago by Atsushi Ono

I have attached a patch for 1.7.x stream. I confirmed that the same fix committed to 1.8 stream before in [27162] can also work fine for 1.7.3.

comment:8 Changed 7 years ago by ykami

Resolution: fixed
Status: reopenedclosed

In [28206]:

Fixes #14186 !strict. Back-port to 1.7.x. If a widget that initiated the transition has a callback, pass it to View.performTransition(). This was a regression bug introduced during the view transition refactoring. Thanks onoat for the patch.

Note: See TracTickets for help on using tickets.