Opened 8 years ago

Closed 7 years ago

#14167 closed defect (worksforme)

when builder is interrupted by ctrl+c, orphan procs are left in node

Reported by: Colin Snover Owned by: Rawld Gill
Priority: low Milestone: 1.8
Component: BuildSystem Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

Related to #13202.

When using node.js, if you hit ctrl+c to interrupt the process a few milliseconds after it has printed “starting parsing resource...”, optimizeRunner.js processes are often left running orphaned in the background, same as #13202, spinning at 100% CPU. This issue is timing-critical as I am not able to reproduce it every single time, but it does happen with the release version of 1.7 builder.

Change History (4)

comment:1 Changed 8 years ago by Rawld Gill

Milestone: tbd1.8
Status: newassigned

comment:2 Changed 8 years ago by ben hockey

Keywords: needsreview added
Priority: highlow

i can't reproduce this. is it still happening? (i just want to close tickets)

comment:3 Changed 8 years ago by Colin Snover

Keywords: needsreview removed

Yes, this is still a reproducible issue. When optimize = "shrinksafe", pressing ctrl+c immediately after “starting parsing resource...” causes 3 java SS processes to be created and orphaned.

comment:4 Changed 7 years ago by Rawld Gill

Resolution: worksforme
Status: assignedclosed

I just tried this again on trunk and all processes are cleaned up correctly. Tried with node and rhino X closure and shrinksafe.

Note: See TracTickets for help on using tickets.