Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14161 closed defect (fixed)

test Image resources corrupted in build

Reported by: Chris Mitchell Owned by: Rawld Gill
Priority: high Milestone: 1.7.1
Component: BuildSystem Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Chris Mitchell)

Recently #14108 was fixed for image resources not being copied properly during builds. Looks like most image dirs do get copied properly, but there may be a new prob with dojox/mobile/tests/images/* Image files in this dir are not the correct file size, and appear blank/corrupted in a browser.

See built directory at http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/mobile/tests/images/ for the corrupted images... they should ilk like these instead: http://archive.dojotoolkit.org/nightly/checkout/dojox/mobile/tests/images/

Change History (9)

comment:1 Changed 8 years ago by Chris Mitchell

Summary: Image resources corrupted in xd build for mobile/tests/imagesImage resources corrupted in build for mobile/tests/images

comment:2 Changed 8 years ago by Chris Mitchell

Description: modified (diff)

comment:3 Changed 8 years ago by Chris Mitchell

Description: modified (diff)

comment:4 Changed 8 years ago by Adam Peller

Milestone: 1.71.7.1

comment:5 Changed 8 years ago by Kenneth G. Franqueiro

So this is interesting: I just tried reproducing the issue, and found that it consistently happens to me if I run the build with rhino (bin=java), but never happens if I run it with node.

Reproduced by checking the images in release/dojo/dojox/mobile/tests/images after running the following build command from util/buildscripts:

./build.sh bin=java profile=standard action=release copyTests=true

comment:6 Changed 7 years ago by Kenneth G. Franqueiro

Version: 1.6.11.7.0b1

comment:7 Changed 7 years ago by bill

Priority: highnormal
severity: majornormal
Summary: Image resources corrupted in build for mobile/tests/imagestest Image resources corrupted in build

Lowering priority since this only affects test files, and there's a workaround: use node instead of rhino. It should still be fixed but shouldn't hold up a 1.7.1 release.

comment:8 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

In [27292]:

fixed profiles to tag images as copyOnly; improved profiles to use best practice expression; fixes #14161

comment:9 Changed 7 years ago by Rawld Gill

In [27300]:

backport [27292] and [27291]; fixes #1440; fixes #14161

Note: See TracTickets for help on using tickets.