Opened 8 years ago

Closed 7 years ago

#14148 closed enhancement (duplicate)

Ability to set filteringSelect dropdown starting value with paging

Reported by: sgourley Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.6.1
Keywords: filteringselect dijit Cc:
Blocked By: Blocking:

Description

It would be great if one had a filteringSelect of years ranging from 1940 - 2050 to pass an argument to a filtering with page size 5 to center it's drop down on an existing value like 2011 for example. A customer does not like to have to page through the values or setting a default value of the current year.

Currently tk and I are not able to hack a solution together.

Change History (8)

comment:1 Changed 8 years ago by bill

Component: GeneralDijit - Form
Resolution: duplicate
Status: newclosed

I can definitely see how that would be useful for dates, but this looks like a dup of #6477.

comment:2 Changed 8 years ago by sgourley

yah possible duplicate. #6477 could work if there were flexibility on where to center the drop down items more so than selected item like listed in #6477.

comment:3 Changed 7 years ago by Adam Peller

Owner: set to Adam Peller
Resolution: duplicatefixed

In [28030]:

Handle NaN in constructor, patch from Helena Halperin (IBM) Fixes #14148

comment:4 Changed 7 years ago by Adam Peller

In [28032]:

Fixes #14148 NaN constructor on 1.7 branch

comment:5 Changed 7 years ago by Adam Peller

In [28033]:

Fixes #14148 NaN constructor on 1.6 branch

comment:6 Changed 7 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

closed accidentally. checkins should have referenced #14158

comment:7 Changed 7 years ago by Adam Peller

Owner: Adam Peller deleted
Status: reopenedassigned

comment:8 Changed 7 years ago by bill

Resolution: duplicate
Status: assignedclosed

This is still a duplicate of #6477.

Note: See TracTickets for help on using tickets.