Opened 8 years ago

Closed 8 years ago

#14140 closed defect (fixed)

Calendar: grid doesn't reflect initially selected date

Reported by: bill Owned by: bill
Priority: high Milestone: 1.8
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Starting w/1.6, continuing to trunk (1.7 rc2), the Calendar won't show the month or day specified via the value parameter. It worked in 1.5.

The problem is in _setValueAttr(), because the compare function returns value since value has already been copied to this.value:

if(!this._isValidDate(this.value) || this.dateFuncObj.compare(value, this.value)){

See the second Calendar in test_Calendar.html. It should be on March, 2008 but it isn't. There was another problem with the value being specified incorrectly, but that's fixed with #13935.

Change History (1)

comment:1 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

In [26943]:

Fix Calendar to obey initially specified value. Fixes #14140 !strict.

Note: See TracTickets for help on using tickets.