Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1412 closed defect (fixed)

ContentPane scriptScope regex replacement fails

Reported by: mumme Owned by: mumme
Priority: high Milestone:
Component: General Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

How to reproduce

html content:

<script>
  this.message = function(){
      alert("hello");
  }
</script>
<div onclick="scriptScope.message()">Not working</div>
<div onclick=" scriptScope.message()">working due to space before keyword</div>
<div id="cl" onclick="scriptScope.message()">working due to attribute before</div>

Change History (3)

comment:1 Changed 13 years ago by mumme

fixed in r5896

comment:2 Changed 13 years ago by mumme

Resolution: fixed
Status: newclosed

comment:3 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.