Opened 10 years ago

Closed 10 years ago

#14110 closed defect (duplicate)

EnhancedGrid: Bad path to css images (dijit/themes/claro/...)

Reported by: jekser Owned by: Evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.7.0b1
Keywords: EnhancedGrid, CSS, Theme, Path, Image Cc:
Blocked By: Blocking:

Description

Bad path to images in /dojox/grid/enhanced/resources/claro/EnhancedGrid.css.

The path should be

../../../../../dijit/themes/claro/images/treeExpandImages.png

but not

../dijit/themes/claro/images/treeExpandImages.png

And if you use the EnhancedGrid? with TreeGrid?, the TreeGrid? is broken.

Change History (7)

comment:1 Changed 10 years ago by Evan

Milestone: tbd1.7.1
Priority: highnormal
severity: majornormal

There isn't "../../../../../dijit/themes/claro/images/treeExpandImages.png" under /dojox/grid/enhanced/resources/claro/EnhancedGrid.css.

The only place for treeExpandImages.png is dojox/grid/resources/claroGrid.css with "../../../dijit/themes/claro/images/treeExpandImages.png" and it's a correct path.

Please provide more details or test cases to reproduce this issue.

Thanks!

comment:2 Changed 10 years ago by Evan

Also TreeGrid? is only expected to be used with "dojox/grid/resources/claroGrid.css"

comment:3 Changed 10 years ago by jekser

URL:

http://download.dojotoolkit.org/release-1.7.0rc1/dojo-release-1.7.0rc1/dojox/grid/tests/enhanced/test_enhanced_grid_pagination.html

Error in Firebug:

"NetworkError?: 404 Not Found - http://download.dojotoolkit.org/release-1.7.0rc1/dojo-release-1.7.0rc1/dojox/grid/enhanced/resources/dijit/themes/claro/images/loadingAnimation.gif"

Example for broken images in TreeGrid?:

<html>
<head>
....
        <link rel="stylesheet" type="text/css" href="/scripts/dojo1.7/dojo/dojo/resources/dojo.css" />
	<link rel="stylesheet" type="text/css" href="/scripts/dojo1.7/dojo/dijit/themes/dijit.css" />
	<style type="text/css">
		@import Url("/scripts/dojo1.7/dojo/dijit/themes/claro/document.css");
		@import Url("/scripts/dojo1.7/dojo/dijit/themes/claro/claro.css");
		
		@import Url("/scripts/dojo1.7/dojo/dojox/grid/resources/Grid.css");
		@import Url("/scripts/dojo1.7/dojo/dojox/grid/resources/claroGrid.css");
		
		@import Url("/scripts/dojo1.7/dojo/dojox/grid/enhanced/resources/EnhancedGrid.css");
		@import Url("/scripts/dojo1.7/dojo/dojox/grid/enhanced/resources/claro/EnhancedGrid.css");

		@import Url("/scripts/dojo1.7/dojo/dojox/grid/enhanced/resources/Pagination.css");
	</style>
...	
</head>
<body class="claro">
...
 <div data-dojo-type="dojox.grid.EnhancedGrid" >...</div>
...
 <div data-dojo-type="dojox.grid.TreeGrid" >...</div>
...
</body>
</html>

Error in Firebug: "NetworkError?: 404 Not Found - http://localhost:3908/scripts/dojo1.7/dojo/dojox/grid/enhanced/resources/dijit/themes/claro/images/treeExpandImages.png"

comment:4 Changed 10 years ago by Evan

Priority: normalhigh

Caused by #14128, changed to high priority for 1.7 RC since many EDG features are broken due to the missed icon resources after built.

Last edited 10 years ago by Evan (previous) (diff)

comment:5 Changed 10 years ago by Evan

Thanks for the detail info, jekser[[BR]] Will follow up this by #14128

Version 0, edited 10 years ago by Evan (next)

comment:6 Changed 10 years ago by Adam Peller

Evan can we close this out as a dup?

comment:7 Changed 10 years ago by Evan

Milestone: 1.7.11.7
Resolution: duplicate
Status: newclosed

Yep, it's duplicate and already fixed with #14128 in 1.7 GA

Note: See TracTickets for help on using tickets.