Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14105 closed defect (fixed)

dojox.socket event handling is not compatible with IE8

Reported by: ergo Owned by: Kris Zyp
Priority: high Milestone: 1.8
Component: Dojox Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

in dojox.socket around line 208 is event handling for messages:

	function fire(type, object, deferred){
		if(socket["on" + type]){
			var event = document.createEvent("HTMLEvents");
			event.initEvent(type, false, false);
			dojo.mixin(event, object);
			event.ioArgs = deferred && deferred.ioArgs;
			socket["on" + type](event);
		}
	}

document.createEvent does not work in Internet Explorer 8 so this component does not work under this browser.

Change History (4)

comment:1 Changed 8 years ago by Adam Peller

Component: DojoX CometdDojox
Owner: changed from Greg Wilkins to Kris Zyp

comment:2 Changed 8 years ago by Kris Zyp

Resolution: fixed
Status: newclosed

In [27502]:

Fix event dispatching with dojox/socket, fixes #14105 !strict

comment:3 Changed 8 years ago by bill

Milestone: tbd1.8

comment:4 Changed 8 years ago by Kris Zyp

#14740 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.