Opened 10 years ago

Closed 10 years ago

#14101 closed defect (invalid)

Error when closing FilteringSelect

Reported by: Michael Fraenkel Owned by: Douglas Hays
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

This was on 1.7rc-1

I have defined a FilteringSelect? hooked up to a Store. When data is populated and the drop down is opened, I clicked on the arrow to close the drop down.

Uncaught TypeError?: Cannot read property 'abort' of undefined declare._setStoreAttr.lang.mixin.query.fetchHandle.fetch.lang.mixin.query ComboBoxMixin?.js:93 dojo.Deferred.promise.cancel.cancel Deferred.js:292 declare._abortQuery _AutoCompleterMixin.js:171 declare._onKey _AutoCompleterMixin.js:202 hitch lang.js:153 c connect.js:119

Attachments (1)

companyAMD.html (939 bytes) - added by Michael Fraenkel 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by bill

Component: DijitDijit - Form
Owner: set to Douglas Hays

Please attach a test case.

comment:2 Changed 10 years ago by bill

Sounds like it may be caused by my changes for supporting dojo.store, but can't tell without the test case.

Changed 10 years ago by Michael Fraenkel

Attachment: companyAMD.html added

comment:3 Changed 10 years ago by Michael Fraenkel

Never mind. My fetch wasn't returning an object in some cases.

Please close.

comment:4 Changed 10 years ago by Douglas Hays

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.