Opened 8 years ago

Closed 7 years ago

#14091 closed defect (invalid)

Tab controls displayed when it should not be

Reported by: jesus.crysist Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.1
Keywords: Cc: jesus.crysist@…
Blocked By: Blocking:

Description

After styling the tabs, in FF 7, Ubuntu 11.04, I get control buttons (left, right and down arrows) on the left and right of the tabs (screenshot 1). This is an issue when using v1.6.1. When I switch to 1.7.05b, I get empty space where those controls should be (screenshot 2) and it disappears after resizing container (using splitter on BC parent).

Attachments (3)

Screenshot 1.png (9.1 KB) - added by jesus.crysist 8 years ago.
v 1.6.1
Screenshot 2.png (9.5 KB) - added by jesus.crysist 8 years ago.
v 1.7.05b
bug.tar.gz (68.7 KB) - added by jesus.crysist 8 years ago.
Test case files

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by jesus.crysist

Attachment: Screenshot 1.png added

v 1.6.1

Changed 8 years ago by jesus.crysist

Attachment: Screenshot 2.png added

v 1.7.05b

comment:1 Changed 8 years ago by bill

You'll need to attach a test case (a self contained HTML file that reproduces the problem).

Changed 8 years ago by jesus.crysist

Attachment: bug.tar.gz added

Test case files

comment:2 Changed 8 years ago by jesus.crysist

I included HTML, theme's CSS and image files in tar.gz archive. Also I saw that the bug reproduced on Chrome.

comment:3 Changed 7 years ago by bill

Resolution: invalid
Status: newclosed

Thanks for the testcase.

To solve your issue is, set controllerWidget="dijit.layout.TabController" on your TabContainer.

The cause of the problem: you've apparently got some custom CSS that makes those tab labels expand to (just over) 100% of the available width. When that happens the ScrollingTabController code sticks in scroll buttons. So I think this is technically not a bug.

Note: See TracTickets for help on using tickets.