Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14086 closed defect (fixed)

Cannot select ComboBox item on some Android devices

Reported by: Atsushi Ono Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

dojox.mobile.ComboBox does not work as expected on some Android devices.

Steps to reproduce:

  1. Open test_FormControls.html
  2. Click ComboBox field
  3. Cannot scroll the combobox popup list nor select item. (Just close popup)

This can be reproduced on Galaxy Tablet.

Attachments (1)

comboboxmenu.patch (481 bytes) - added by Atsushi Ono 8 years ago.
[patch][ccla] Fix for _ComboBoxMenu.js

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Atsushi Ono

Attachment: comboboxmenu.patch added

[patch][ccla] Fix for _ComboBoxMenu.js

comment:1 Changed 8 years ago by Atsushi Ono

It is because the workaround code for Android input field jumping issue is enabled unexpectedly in scrollable widget inside ComboBox popup menu. I attached the fix to it.

comment:2 Changed 8 years ago by ykami

Resolution: fixed
Status: newclosed

In [26858]:

Fixes #14086 !strict. Disabled the android workaround.

comment:3 Changed 8 years ago by ykami

Thank you onoat for the patch.

comment:4 Changed 8 years ago by Adam Peller

Milestone: tbd1.7
Note: See TracTickets for help on using tickets.