Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14082 closed defect (invalid)

transition to dynamic view fails on safari mobile browser

Reported by: zhangyp Owned by: ykami
Priority: high Milestone: tbd
Component: DojoX Mobile Version: 1.7.0b1
Keywords: Cc: basselmourjan@…, Chris Mitchell, Ming Zhe Huang, Atsushi Ono
Blocked By: Blocking:

Description

This bug is reported by user on dojo-interest. We need to check whether it can be reproduced on latest code and figure out how to solve the problem by root cause. I am asking the user to provide his test case so that it could help on understanding of the problem.

while building a mobile app, I extended dojox.mobile.View's PerformTransition?() to handle and require missing files dynamically then it recalls itself to continue with the transition. it works fine on PC browsers but fails on iphone safari browser and the following error is enountered "NOT_FOUND_ERR: DOM Exception 8: An Attempt was made to reference a Node in a context where it does not exist."

after tracing it back, I found that the error is caused by a "Workaround for iPhone flicker issue (only when scrollable.js is loaded)" found in dojox.mobile.View._doTransition() - Line 361 and the exact code that is failing is "win.body().removeChild(dm._iwBgCover);"

using dojo-1.7.0-b6, so it could be a bug!

Attachments (1)

dojox-mobile-transition-test.rar (3.1 KB) - added by zhangyp 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by ykami

Cc: Atsushi Ono added

comment:2 Changed 8 years ago by ykami

Resolution: invalid
Status: newclosed

The reporter copy & pasted the code from older revision of View.js.

Changed 8 years ago by zhangyp

comment:3 Changed 8 years ago by zhangyp

does it mean it does not have any problem on latest code?

comment:4 Changed 8 years ago by ykami

Right. Even though copy & paste the code is not recommended (even overriding of performTransition is not recommended in the first place), the problem should disappear if you copy & paste the latest code.

Note: See TracTickets for help on using tickets.