Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14081 closed defect (fixed)

Broken test cases under dojox/layout/tests/*

Reported by: Evan Owned by:
Priority: high Milestone: 1.7
Component: DojoX Layout Version: 1.7.0b1
Keywords: dojox, layout Cc: Chris Mitchell, Rawld Gill, bill
Blocked By: Blocking:

Description

The following test case failed in my svn repository(latest checkout), with - "dojo.js Error: multipleDefine"

  • dojox/layout/tests/test_TouchStackContainer.html
  • dojox/layout/tests/test_FloatingPane.html
  • dojox/layout/tests/test_ExpandoPane.html
  • dojox/layout/tests/test_ScrollPane.html
  • dojox/layout/tests/test_ScrollPaneSingle.html

But these test cases run well on nightly build after compressed

Attachments (1)

14081.jpg (68.5 KB) - added by Evan 8 years ago.
More detail error info

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Evan

Attachment: 14081.jpg added

More detail error info

comment:1 Changed 8 years ago by ben hockey

Cc: bill added

dojox/layout/tests/test_TouchStackContainer.html is failing with "Could not load class 'dijit.layout.StackController?" because dijit.layout.StackContainer? no longer pulls in dijit.layout.StackController?. if this is considered a regression then dijit.layout.StackContainer? needs to be changed, otherwise the test can be update so that dijit.layout.StackController? is included.

this defect is unrelated to the loader - cc bill to get his thoughts.

comment:2 Changed 8 years ago by ben hockey

btw - the test also includes _testCommon.js that is a 404 and it has been this way for quite a while.

comment:3 Changed 8 years ago by ben hockey

test_FloatingPane.html - remove the following 2 lines since including modules via script tags is not supported for source.

	<!-- for debugging: -->
	<script type="text/javascript" src="../FloatingPane.js"></script>

i suspect all the others are the same issue.

Last edited 8 years ago by ben hockey (previous) (diff)

comment:4 Changed 8 years ago by ben hockey

test_ScrollPaneSingle.html has no errors for me but i confirmed that the others all have script tags that try to load modules from source. remove the tags and the problem goes away. interestingly, these problems have probably existed for months now so i'm not sure they're blockers if this is the first we're hearing about them.

comment:5 Changed 8 years ago by ben hockey

i'll check in a fix for these soon.

comment:6 Changed 8 years ago by ben hockey

Resolution: fixed
Status: newclosed

oops typo in ticket number in commit r26852. if anyone thinks the dijit.layout.StackController/StackContainer? stuff is a regression then open a new ticket.

comment:7 in reply to:  1 Changed 8 years ago by bill

Replying to neonstalwart:

dojox/layout/tests/test_TouchStackContainer.html is failing with "Could not load class 'dijit.layout.StackController?" because dijit.layout.StackContainer? no longer pulls in dijit.layout.StackController. if this is considered a regression then dijit.layout.StackContainer needs to be changed, otherwise the test can be update so that dijit.layout.StackController? is included.

this defect is unrelated to the loader - cc bill to get his thoughts.

Oh actually StackContainer should pull in StackController in legacy (non-AMD) mode, I'll check in a fix for that. But your fix is good too, because user code shouldn't be assuming that (and it won't work come 2.0)

comment:8 Changed 8 years ago by bill

In [26854]:

just updating deprecated attr() call to use set() instead, refs #14081

comment:9 Changed 8 years ago by bill

In [26855]:

make StackContainer pull in StackController in legacy (non-amd) mode, for back-compat, refs #14081 !strict

Note: See TracTickets for help on using tickets.