Opened 8 years ago

Closed 4 years ago

#14022 closed enhancement (duplicate)

Opacity animation for dojox.gfx shapes

Reported by: jesus.crysist Owned by: Eugene Lazutkin
Priority: high Milestone: 1.11
Component: DojoX GFX Version: 1.6.1
Keywords: Cc: jesus.crysist@…, Patrick Ruzand
Blocked By: Blocking:

Description

When I try to animate opacity of a shape, I don't get a result in Google Chrome on Ubuntu (apparently, it have a bug when rendering elements with opacity=0, the element's fully opaque(!))

It would be nice use rgba for animation. If I set fill for example to [255, 255, 255, 1], I can use [255, 255, 255, 0] to animate opacity in fx.animateFill() function. Now it changes rgba to rgb in fill attribute and animates fill-opacity.

My example: http://jsbin.com/ayocik/5/

tk told me last night to file a bug report but I filed one on Chrome's tracker and I'm still hoping they'll fix it soon.

Change History (2)

comment:1 Changed 8 years ago by Chris Mitchell

Cc: Patrick Ruzand added

comment:2 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: duplicate
Status: newclosed

Duplicate of #13780.
Duplicate of #13780. That said, in order for this to ever get done, someone will need to create a pull request.

Note: See TracTickets for help on using tickets.