Opened 8 years ago

Closed 8 years ago

#13980 closed defect (duplicate)

[meta] many IE6 regression test failures

Reported by: bill Owned by:
Priority: high Milestone: 1.7
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

I see failures in the dijit regression on IE6 in:

  • dijit/_base/place - tracking this in #12418
  • Calendar_a11y - tracking in #13722
  • Tree - didn't reproduce when running Tree.html or dijit/tests/tree/runTests.html by themselves, guess it's OK
  • Editor_LinkDialog- didn't reproduce when running Editor_LinkDialog.html or dijit/tests/editor/runTests.html by themselves, guess it's OK

These tests failed for me but when I ran dijit/tests/runTests.html, but when I run dijit.tests.form.module by itself they work, so I guess they are OK:

  • ButtonMixin
  • ValidationTextBox
  • TimeTextBox
  • AutoCompleter_mixin
  • ComboBox_mouse
  • ExpandingTextAreaMixin

These tests failed for me but when I ran dijit/tests/runTests.html, but when I run dijit.tests._BidiSupport.module by itself they work, so I guess they are OK:

  • dijit.tests._BidiSupport.form.noTextDirTextWidgets
  • dijit.tests._BidiSupport.inheritance.Inher-MarkupContainers
  • dijit.tests._BidiSupport.tree.TreeRootlessCustomIcons.html

Marking as high priority since IE6 is still a major platform for our users. I don't personally care though if we fix before or after the release.

Change History (4)

comment:1 Changed 8 years ago by bill

Description: modified (diff)

comment:2 Changed 8 years ago by Chris Mitchell

Priority: highnormal

reducing severity to medium, we agreed on irc that this should not gate rc1

comment:3 Changed 8 years ago by bill

Description: modified (diff)

comment:4 Changed 8 years ago by bill

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Closing this, tracking remaining issues in other tickets.

There might still be a new memory leak on IE that's causing the regression suite when run altogether (in one pass) to fail. Could be from the event changes. Not sure.

Note: See TracTickets for help on using tickets.