Opened 8 years ago

Closed 8 years ago

#13954 closed defect (fixed)

build crashes when encountering special files

Reported by: dante Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Running a 1.7 build against a working 1.6.1 codebase as a regression tests caused some issues.

src/myns/tests/nls/foo.txt

is found to be an nls bundle, and is parsed as such. This causes the build to crash and the proc to zombie. This is an incidental, because of the presence of /nls/ in the filename, despite being in /tests/ and having a .txt extension.

there are two places in writeAmd transform which use input in an unchecked manner, causing the process to crash. they are triggered by the above file.

simply adding a bit of truthy checking allows the build to successfully process over the 1.6.1 codebase and nearly perfectly wraps the whole application in AMD format.

patch defending against undefined usage attached

Attachments (1)

unchecked.patch (843 bytes) - added by dante 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by dante

Attachment: unchecked.patch added

comment:1 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:2 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

In [26700]:

make writeAmd more-gentle with non-amd resources; fixes #13954; thanks dante; fix typo; thanks chris barber; !strict

Note: See TracTickets for help on using tickets.