Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#13906 closed enhancement (fixed)

Upgrade to CLDR v21.0

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 1.8
Component: Internationalization Version: 1.6.1
Keywords: Cc: LQQI@…, Evan
Blocked By: Blocking:

Description (last modified by Adam Peller)

http://unicode-inc.blogspot.com/2012/02/unicode-releases-common-locale-data.html

Somewhere along the line, CLDR added an extra digit to its version numbers (1.9, 2.0, 21.0...)

Attachments (2)

gregorian.js (481 bytes) - added by Evan 8 years ago.
en test file put under - dojo/cldr/nls/en
gregorian.2.js (1.3 KB) - added by Evan 8 years ago.
root test file put under dojo/cldr/nls

Download all attachments as: .zip

Change History (27)

comment:1 Changed 8 years ago by Adam Peller

Description: modified (diff)
Type: defectenhancement

comment:2 Changed 8 years ago by Adam Peller

Description: modified (diff)
Milestone: 2.01.8

comment:3 Changed 8 years ago by Adam Peller

In [28071]:

Upgrade to CLDRv21.0 and alter xslt scripts to work with new schema. Refs #13906

comment:4 Changed 8 years ago by Adam Peller

In [28072]:

Update tests to match CLDR v21.0. Refs #13906 !strict

comment:5 Changed 8 years ago by Adam Peller

In [28073]:

Update data to match CLDR v21.0 release. Refs #13906, Fixes #13495

comment:7 Changed 8 years ago by Adam Peller

In [28074]:

build output from CLDR v21.0 refs #13906

comment:8 Changed 8 years ago by Adam Peller

In [28075]:

zh-hk and zh-tw missing from new build. remove old data. refs #13906

comment:9 Changed 8 years ago by Adam Peller

Description: modified (diff)
Summary: Upgrade to CLDR 2.0Upgrade to CLDR v21.0

comment:10 Changed 8 years ago by Adam Peller

Cc: Evan added

inherit script doesn't seem to be working either. for example: dojo/cldr/nls/en/gregorian.js is missing months-standAlone-abbr

comment:11 in reply to:  10 Changed 8 years ago by Evan

Replying to peller:

inherit script doesn't seem to be working either. for example: dojo/cldr/nls/en/gregorian.js is missing months-standAlone-abbr

Just had a quick try, seems it's related with xxx@localeAlias stuff, I simplify the scenario by only applying 'alias.js' to the two attached gregorian.js files(1 under dojo/cldr/nl, 1 under dojo/cldr/nls/en), and also uncomment logstr, then I met with an error saying

"alias: an exception occurred: ReferenceError: "ActiveXObject" is not defined."

which is an exception from alias.js:

try{
        var bundle = dojo.i18n.getLocalization('dojo.cldr', BUNDLES[i], locale); //get bundle
        var nativeSrcBundle = getNativeBundle(jsFileName);//bundle not flattened
}catch(e){
	logStr += "alias: an exception occurred: "+e;/* simply ignore if no bundle found*/
}

So seems the bundle is not correctly obtained from dojo.i18n.getLocalization() in Rhino

And that's the clue I've found yet

Changed 8 years ago by Evan

Attachment: gregorian.js added

en test file put under - dojo/cldr/nls/en

Changed 8 years ago by Evan

Attachment: gregorian.2.js added

root test file put under dojo/cldr/nls

comment:12 Changed 8 years ago by Evan

I think the reason why "months-standAlone-abbr" missed is due to the above exception which stops all follow up steps to process the alias stuff - the expected behavior would be: in dojo/cldr/nls/en/gregorian.js, content of months-standAlone-abbr should be exactly the same as

	"months-format-wide": [
		"January",
		"February",
		"March",
		"April",
		"May",
		"June",
		"July",
		"August",
		"September",
		"October",
		"November",
		"December"
	],

as this alias mapping is defined in root dojo/cldr/nls/en/gregorian.js, but this copying is stopped by the exception.

comment:13 Changed 8 years ago by Adam Peller

for starters, the code at the top of cldrUtil that does a "monkey patch" of dojo.xhrGet no longer works in 1.7

comment:14 Changed 8 years ago by Adam Peller

In [28459]:

replace xhr monkey patch for Rhino with paths replacement Refs #13906

comment:15 Changed 8 years ago by Adam Peller

In [28467]:

refs #13906 #15125 update CLDR 2.0 with updated build scripts

comment:16 Changed 8 years ago by Adam Peller

In [28483]:

refs #13906 update to maintenance release 21.0.1

comment:17 Changed 8 years ago by Adam Peller

Resolution: fixed
Status: newclosed

In [28486]:

Fixes #13906 run scripts against updated v21.0.1 data

comment:18 Changed 8 years ago by Adam Peller

r28459 is probably no longer necessary, due to rawld's fix in r28478

comment:19 Changed 8 years ago by Adam Peller

In [28487]:

Refs #13906 v21.0.1 update

comment:20 Changed 8 years ago by Adam Peller

In [28528]:

refs #13906 remove unused files

comment:21 Changed 8 years ago by Adam Peller

In [28555]:

run scripts against CLDR v21 Refs #13906

comment:22 Changed 8 years ago by Adam Peller

In [28556]:

Refs #13906 missing one new resource

comment:23 Changed 7 years ago by Adam Peller

In [30139]:

run scripts against CLDR v21 Refs #13906, #15424

comment:24 Changed 7 years ago by Adam Peller

In [30140]:

run scripts against CLDR v21 Refs #13906, #15424, #16281
-This line, and those below, will be ignored--

M nls/da/buddhist.js
M nls/da/number.js
M nls/da/currency.js
M nls/da/gregorian.js
M nls/da/islamic.js
M nls/hebrew.js
M nls/de/buddhist.js
M nls/de/number.js
M nls/de/currency.js
M nls/de/gregorian.js
M nls/de/islamic.js
M nls/sv/buddhist.js
M nls/sv/number.js
M nls/sv/currency.js
M nls/sv/hebrew.js
M nls/sv/gregorian.js
M nls/sv/islamic.js
M nls/gregorian.js
M nls/ja/buddhist.js
M nls/ja/number.js
M nls/ja/currency.js
M nls/ja/hebrew.js
M nls/ja/gregorian.js
M nls/ja/islamic.js
M nls/he/number.js
M nls/he/currency.js
M nls/he/hebrew.js
M nls/he/gregorian.js
M nls/he/islamic.js
M nls/islamic.js
M nls/fi/buddhist.js
M nls/fi/number.js
M nls/fi/currency.js
M nls/fi/hebrew.js
M nls/fi/gregorian.js
M nls/fi/islamic.js
M nls/nb/buddhist.js
M nls/nb/number.js
M nls/nb/currency.js
M nls/nb/gregorian.js
M nls/nb/islamic.js
M nls/fr/buddhist.js
M nls/fr/number.js
M nls/fr/currency.js
M nls/fr/hebrew.js
M nls/fr/gregorian.js
M nls/fr/islamic.js
M nls/nl/buddhist.js
M nls/nl/number.js
M nls/nl/currency.js
M nls/nl/hebrew.js
M nls/nl/gregorian.js
M nls/nl/islamic.js
M nls/pl/buddhist.js
M nls/pl/number.js
M nls/pl/currency.js
M nls/pl/hebrew.js
M nls/pl/gregorian.js
M nls/pl/islamic.js
M nls/th/buddhist.js
M nls/th/number.js
M nls/th/currency.js
M nls/th/hebrew.js
M nls/th/gregorian.js
M nls/th/islamic.js
M nls/hu/buddhist.js
M nls/hu/number.js
M nls/hu/currency.js
M nls/hu/hebrew.js
M nls/hu/gregorian.js
M nls/hu/islamic.js
M nls/ro/buddhist.js
M nls/ro/number.js
M nls/ro/currency.js
M nls/ro/hebrew.js
M nls/ro/gregorian.js
M nls/ro/islamic.js
M nls/buddhist.js
M nls/zh/buddhist.js
M nls/zh/number.js
M nls/zh/currency.js
M nls/zh/hebrew.js
M nls/zh/gregorian.js
M nls/zh/islamic.js
M nls/zh-hk/number.js
M nls/zh-hk/currency.js
M nls/zh-hk/gregorian.js
M nls/en-ca/gregorian.js
M nls/ca/number.js
M nls/ca/currency.js
M nls/ca/gregorian.js
M nls/pt/buddhist.js
M nls/pt/number.js
M nls/pt/currency.js
M nls/pt/hebrew.js
M nls/pt/gregorian.js
M nls/pt/islamic.js
M nls/tr/buddhist.js
M nls/tr/number.js
M nls/tr/currency.js
M nls/tr/hebrew.js
M nls/tr/gregorian.js
M nls/tr/islamic.js
M nls/ru/buddhist.js
M nls/ru/number.js
M nls/ru/currency.js
M nls/ru/hebrew.js
M nls/ru/gregorian.js
M nls/ru/islamic.js
M nls/en-gb/buddhist.js
M nls/en-gb/number.js
M nls/en-gb/gregorian.js
M nls/en-gb/islamic.js
M nls/fr-ch/number.js
M nls/fr-ch/gregorian.js
M nls/el/buddhist.js
M nls/el/number.js
M nls/el/currency.js
M nls/el/hebrew.js
M nls/el/gregorian.js
M nls/en/buddhist.js
M nls/en/number.js
M nls/en/currency.js
M nls/en/gregorian.js
M nls/en/islamic.js
M nls/ar/buddhist.js
M nls/ar/number.js
M nls/ar/currency.js
M nls/ar/hebrew.js
M nls/ar/gregorian.js
M nls/ar/islamic.js
M nls/number.js
M nls/pt-pt/buddhist.js
M nls/pt-pt/number.js
M nls/pt-pt/gregorian.js
M nls/pt-pt/islamic.js
M nls/en-au/gregorian.js
M nls/cs/buddhist.js
M nls/cs/number.js
M nls/cs/currency.js
M nls/cs/gregorian.js
M nls/cs/islamic.js
M nls/currency.js
M nls/es/buddhist.js
M nls/es/number.js
M nls/es/currency.js
M nls/es/gregorian.js
M nls/es/islamic.js
M nls/zh-hant/buddhist.js
M nls/zh-hant/number.js
M nls/zh-hant/currency.js
M nls/zh-hant/hebrew.js
M nls/zh-hant/gregorian.js
M nls/zh-hant/islamic.js
M nls/ko/buddhist.js
M nls/ko/number.js
M nls/ko/currency.js
M nls/ko/gregorian.js
M nls/zh-tw/number.js
M nls/zh-tw/currency.js
M nls/zh-tw/gregorian.js
M nls/it/buddhist.js
M nls/it/number.js
M nls/it/currency.js
M nls/it/gregorian.js
M nls/it/islamic.js
M nls/sk/number.js
M nls/sk/currency.js
M nls/sk/gregorian.js
M nls/sl/number.js
M nls/sl/currency.js
M nls/sl/gregorian.js

comment:25 Changed 7 years ago by Adam Peller

In [30141]:

Add missing translations Refs #13906

comment:26 Changed 7 years ago by Adam Peller

In [30142]:

Add missing translations Refs #13906

Note: See TracTickets for help on using tickets.