Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13905 closed defect (invalid)

The mobile themes and test files need to be updated

Reported by: ykami Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: 1.7-mobile Cc:
Blocked By: Blocking:

Description

  • Alignment of the icons (e.g. the plus icon) in the BlackBerry theme is incorrect. (test_BlackBerry-Heading.html)
  • Rounded corners of the buttons in the BlackBerry theme are dirty. (test_BlackBerry-Heading.html)
  • Font size of the buttons in the BlackBerry theme is too large. (test_BlackBerry-Heading.html)
  • Alignment of the icons (e.g. the plus icon) in the Android theme is incorrect. (test_Android-Heading.html)
  • Rounded corners of the heading buttons in the BlackBerry theme are dirty. (test_BlackBerry-Heading.html)
  • Vertical alignment of the heading label text and TabBarButton text in the Android theme is not correct. (test_BlackBerry-Heading.html)
  • Left margin of the back button is too large. (iPhone, Android, and BlackBerry)
  • Vertical alignment of the ListItem content in the Custom theme is not correct.
  • Transition test files should not have colorful background to be able to run tests in more typical scenarios.
  • etc.

Change History (20)

comment:1 Changed 8 years ago by ykami

In [26575]:

Refs #13905 !strict Added a couple of class names to dom nodes to be used for styling. Removed a magic number 8 (which was 8px margin for ListItem? icons) from dojox.mobile.setupIcon().

comment:2 Changed 8 years ago by ykami

In [26576]:

Refs #13905 !strict DOH test automation fixes.

comment:3 Changed 8 years ago by ykami

In [26577]:

Refs #13905 !strict Sample images for tests.

comment:4 Changed 8 years ago by ykami

In [26578]:

Refs #13905 !strict Fixed test files. ToolBarButton? should use the icon property rather than the class attribute to specify a dom button. Removed background colors from transition animation tests.

comment:5 Changed 8 years ago by ykami

In [26579]:

Refs #13905 !strict. Removed themes/common/base.less. Improved compat (TabBar?, Heading, etc.). Renamed mblToolbarButton to mblToolBarButton. Removed the back button's "neck" node. Removed border radius from the android buttons. Removed border from the bb buttons for better appearances. Fixed the back button margins. And more...

comment:6 Changed 8 years ago by ykami

Resolution: fixed
Status: newclosed

comment:7 Changed 8 years ago by Paul Christopher

Resolution: fixed
Status: closedreopened

Not sure whether the changes made by this ticket are the cause, but as of 2011-09-16, iPad/ iPhone styles are broken when viewed on Firefox 6.02, see latest nightly builds on

http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/mobile/tests/test_iPhone-Heading.html

http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/mobile/tests/test_iPad-Heading.html

comment:8 Changed 8 years ago by ykami

Resolution: invalid
Status: reopenedclosed

Thanks for letting me know this. It was #13916 that broke the compat support for FF, not this one. I reverted some of the changes made with #13916.

comment:9 Changed 8 years ago by ykami

In [26688]:

Refs #13905 !strict Fixed back-button color for iPad.

comment:10 Changed 8 years ago by ykami

In [26724]:

Refs #13905 !strict. Small adjustments for ListItem? and ToggleButton?.

comment:11 Changed 8 years ago by ykami

In [26815]:

Refs #13905 !strict. Minor cosmetic adjustments for desktop browsers.

comment:12 Changed 8 years ago by ykami

In [26816]:

Refs #13905 !strict. Minor cosmetic fixes. Background image for SpinWheel? on IE. The custom theme's font size.

comment:13 Changed 8 years ago by ykami

In [26819]:

Refs #13905 !strict. Minor cosmetic fixes. Fixed the desktop compat images that have jagged edges.

comment:14 Changed 8 years ago by ykami

In [26821]:

Refs #13905 !strict. Minor cosmetic fixes. Fixed the desktop compat images that have jagged edges.

comment:15 Changed 8 years ago by ykami

In [26825]:

Refs #13905 !strict. Minor cosmetic fixes. Fixed a jagged edged image. Apply the alpha filter to DOM buttons on IE6. (The fix applies only to IE6.)

comment:16 Changed 8 years ago by ykami

In [26830]:

Refs #13905 !strict. Minor cosmetic fixes. Slightly changed BlackBerry? theme's TabBarButton? color.

comment:17 Changed 8 years ago by ykami

In [26836]:

Refs #13905 !strict. Minor cosmetic fixes. Fixed an IE9 problem where Tooltip width becomes wider than expected. The fix applies only to IE9.

comment:18 Changed 8 years ago by ykami

In [26842]:

Refs #13905 !strict. Minor cosmetic fixes. Slightly adjusted alignment of IconContainer?'s close button. Fixed Overlay's styles and test files so that the content is correctly center-aligned on desktop browsers.

comment:19 Changed 8 years ago by ykami

In [26850]:

Refs #13905 !strict. Minor cosmetic fixes. Slightly adjusted duration of transition animations on android tablet. The fix applies only to android tablets.

comment:20 Changed 8 years ago by ykami

In [26857]:

Refs #13905 !strict. Minor cosmetic fixes. Slightly adjusted TabBarButton? colors. The fix applies only to desktop browsers.

Note: See TracTickets for help on using tickets.