Opened 8 years ago

Closed 8 years ago

#13903 closed defect (duplicate)

Handling of null-values in StoreSeries

Reported by: cschanz Owned by: Eugene Lazutkin
Priority: high Milestone: tbd
Component: Charting Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

According to this example: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/charting/tests/test_nulls.html the charting component is capable of plotting null-values as gaps.

I am getting values from a JsonRest? Store with a StoreSeries? in the form [{"timestamp": 1315692000000.0, "value": 43.137300000000003}, {"timestamp": 1315692300000.0, "value": 42.981199999999994}]

But how can I pass null-values to a StoreSeries?? I have tried the following: [{"timestamp": 1315692000000.0, "value": 43.137300000000003}, {"timestamp": 1315692000000.0, "value": null}, {"timestamp": 1315692300000.0, "value": 42.981199999999994}] => null is plottet as 0 (zero)

[{"timestamp": 1315692000000.0, "value": 43.137300000000003}, null, {"timestamp": 1315692300000.0, "value": 42.981199999999994}] => gives no plot and the following error message in Firebug: TypeError?: _7 is null (I am using release-1.7.0b5)

'timestamp' and 'value' are defined as x- and y-axis values.

Is there another way to pass null-values to a StoreSeries??

Change History (1)

comment:1 Changed 8 years ago by cjolif

Resolution: duplicate
Status: newclosed

This is a duplicate of #6812

Null values are supported only for index based data sets [ y1, y2... , null, yn] not for {x,y} data set. Obviously this must be improved and work will be done in the context of the #6812 ticket.

Note: See TracTickets for help on using tickets.