Opened 8 years ago

Closed 8 years ago

#13892 closed defect (fixed)

getParent function added to _WidgetBase.js broke dojox.mobile.parser

Reported by: Ed Chatelain Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: Cc: bill, ykami
Blocked By: Blocking:

Description

getParent function added to _WidgetBase.js broke dojox.mobile.parser when using dojox.mvc. The problem is that the dojox.mobile.parser is no longer calling startup for some dojox.mobile.textbox widgets where it had in the past, this is the code that would call startup() before:

!args.noStart && w.startup && !w._started && (!w.getParent
!w.getParent()) && w.startup();

With the new getParent function it is returning a parent where it had not in the past. The dojo.parser removed the check for getParent() before the call to startup, so I think it should also be removed from the dojox.mobile.parser.

If you want to test this, you can update: /dojox/mvc/tests/mobile/test_iPhone-shipto-billto.html to use the dojox.mobile.parser, and then run the test, none of the values will be set into the text fields because startup is not being called.

Thanks, Ed

Change History (1)

comment:1 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

In [26543]:

remove getParent() calls from dojox/mobile/parser, same as for dojo/parser in [26531], refs #13886, fixes #13892, !strict.

Note: See TracTickets for help on using tickets.