Opened 8 years ago

Closed 7 years ago

#13823 closed defect (duplicate)

dojox.mvc.StatefulModel Date binding

Reported by: cavey Owned by: Ed Chatelain
Priority: high Milestone: tbd
Component: DojoX MVC Version: 1.7.0b1
Keywords: Cc: rahul
Blocked By: Blocking:

Description (last modified by bill)

I'm trying to bind a js Date using dojox.mvc.StatefulModel.

dojox.mvc.StatefulModel._createModel appears to incorrectly handle the date, think it should directly assign the date to the value and not be handled in the isObject case. Test becomes ...

if(lang.isObject(obj) && !(obj instanceof Date)){

Change History (5)

comment:1 Changed 8 years ago by bill

Component: GeneralDojoX MVC
Description: modified (diff)
Owner: set to rahul

comment:2 Changed 8 years ago by Ed Chatelain

Do you have a simple testcase which is failing without this update? Thanks, Ed

comment:3 Changed 8 years ago by Ed Chatelain

I believe this was fixed with this changeset: [26660] can you verify that it is now fixed? Thanks

comment:4 Changed 7 years ago by Adam Peller

Cc: rahul added; andrew.cave@… removed
Owner: changed from rahul to Ed Chatelain

comment:5 Changed 7 years ago by cjolif

Resolution: duplicate
Status: newclosed

Duplicate of #13899.

Note: See TracTickets for help on using tickets.