Opened 8 years ago

Closed 8 years ago

#13802 closed defect (fixed)

dojox.mobile.Tooltip is partly hidden by dojox.mobile.Heading

Reported by: ebengtso Owned by: Douglas Hays
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

Tooltip is partly hidden by dojox.mobile.Heading, when showing a dojox.mobile.Tooltip with an anchor set inside dojox.mobile.Heading.

Workaround: set the z-index for dojox.mobile.Tooltip div to 999

<div> <div dojoType="dojox.mobile.Heading" fixed="top"> <div onClick="dijit.byId('changeDashboardTooltip').show(this, ['below-centered','after'])" dojoType="dojox.mobile.ToolBarButton?" style="float:left;">Change Dashboard</div> </div> <div id="changeDashboardTooltip" dojoType="dojox.mobile.Tooltip" style="z-index:999">content</div> </div>

Change History (5)

comment:1 Changed 8 years ago by ykami

Cc: Douglas Hays added

Doug, Heading has z-index:2, which is probably the cause of this problem. I didn't want to use z-index, but I had to do so for some reason. Do you think we should give higher z-index to Tooltip?

comment:2 Changed 8 years ago by ebengtso

You can probably find a tip on the fix by looking at the dijit.TooltipDialog? sources, because after having replaced dojox.mobile.Tooltip with dijit.TooltipDialog? and removed the z-index, the Tooltipo displayed correctly.

comment:3 Changed 8 years ago by ykami

Cc: Douglas Hays removed
Owner: changed from ykami to Douglas Hays

Doug, should we provide a reasonable default z-index unless we have some smarter solution?

comment:4 Changed 8 years ago by Douglas Hays

Milestone: tbd1.7

comment:5 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

In [26586]:

Fixes #13802, #13829, #13830. Add default z-index of Tooltip and Overlay to 2000 to match TooltipDialog? in dijit. Add full screen cover to intercept click events that can close either. The default is to close Tooltip but not Overlay. When onclick outside the popup fires, Opener calls widget.onBlur. If false is returned, then the widget ignores the click. Anything else will cause widget.hide() to be called.

Note: See TracTickets for help on using tickets.