Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13767 closed defect (fixed)

test_Opener-RoundSelectList-async.html does not work on a blackberry

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

Run test_Opener-RoundSelectList?-async.html on a blackberry and only the header shows at the bottom and not the selection list.

Change History (6)

comment:1 Changed 8 years ago by Douglas Hays

Version: 1.6.11.7.0b1

comment:2 Changed 8 years ago by Douglas Hays

Priority: normalhigh

comment:3 Changed 8 years ago by ykami

This is not a blackberry specific issue. It does not work on android devices either. There is a timing issue with loading of theme css files. Ironically, only when the theme css fails to be applied in time, it works. So, if you use <link> tags to load the theme css files instead of deviceTheme, the problem is reproducible even on Chrome. I think height of the select list needs to be given in some way.

comment:4 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

In [26423]:

Fixes #13764, #13767. Change scrollable:resize's calculation of height=auto to better reflect actual size of popup and also to understand css height overrides. Added call to resize in Opener:show to let the size change dynamically. !strict

comment:3 Changed 8 years ago by ykami

In [26463]:

Refs #13764, #13767 !strict. Adding dom-geometry in the deps list broke the non-dojo test cases. Temporarily added a null for dom-geometry, but it should be be used in this module.

comment:4 Changed 8 years ago by Douglas Hays

In [26467]:

Refs #13767. Move bottom pad/border calculation to Tooltip (using fixedFooterHeight) and remove dom-geometry dependency from scrollable.js. !strict

Note: See TracTickets for help on using tickets.