Opened 8 years ago

Closed 7 years ago

#13757 closed defect (fixed)

dojox/app doesn't run on FF

Reported by: bill Owned by: Ed Chatelain
Priority: high Milestone: 1.9
Component: DojoX App Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

On FF/mac I loaded dojox/app/tests/modelApp, then clicked "Simple Data Binding". The screen has two things on top of each other:

Attachments (2)

screenshot.gif (18.4 KB) - added by bill 8 years ago.
ffTrunk.gif (16.1 KB) - added by bill 8 years ago.
home button glitchy and other button text wrong color

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by bill

Attachment: screenshot.gif added

comment:1 Changed 8 years ago by zhangyp

I need to take a close look at the sample on FF. Currently, the applications are using dojox.mobile controls and it needs to require dojox.mobile.compat to view that sample in FF. Even though with compat mode, it will not look as good as webkit based browsers. The sample applications work well on chrome and safari. I will see whether enabling the compat mode will make it better on firefox.

comment:2 Changed 8 years ago by bill

Summary: dojox/app completely broken?dojox/app doesn't run on FF

comment:3 Changed 8 years ago by zhangyp

The new transition utility has been applied to run on firefox. Right now the problem is on how to execute js code imported on the view html template page.

comment:4 Changed 8 years ago by bill

Component: DojoxDojoX App

comment:5 Changed 8 years ago by Eric Wang

add "dojox/mobile/_compat" in the dependencies section and it works now.

comment:6 Changed 8 years ago by cjolif

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

comment:7 Changed 8 years ago by bill

Resolution: fixed
Status: closedreopened

Admittedly it looks better than before, but it still looks weird:

home button glitchy and other button text wrong color

Changed 8 years ago by bill

Attachment: ffTrunk.gif added

home button glitchy and other button text wrong color

comment:8 Changed 7 years ago by cjolif

Owner: changed from zhangyp to Ed Chatelain
Status: reopenedassigned

comment:9 Changed 7 years ago by cjolif

Milestone: 1.8tbd

comment:10 Changed 7 years ago by Ed Chatelain

Milestone: tbd1.9
Resolution: fixed
Status: assignedclosed

Sorry I don't know when this was fixed, but it looks fine for me as of 1.9.

Note: See TracTickets for help on using tickets.