Opened 8 years ago

Closed 8 years ago

#13722 closed defect (fixed)

Calendar: No auditive indication for selected and disabled days

Reported by: Katie Vance Owned by: Becky Gibson
Priority: high Milestone: 1.8
Component: Accessibility Version: 1.6.1
Keywords: a11y, jaws Cc: Becky Gibson
Blocked By: Blocking:

Description

Add aria-selected and aria-disabled onto the gridcell.

Attachments (1)

13722.patch (3.7 KB) - added by Katie Vance 8 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by bill

Thanks. Are the false settings necessary or useful?

template.setAttribute("aria-selected", false);

and

template.setAttribute("aria-disabled", false);

It seems like if there was no setting at all it would imply that the cell was enabled but unselected.

comment:2 Changed 8 years ago by Katie Vance

According to http://www.w3.org/TR/wai-aria/states_and_properties, if aria-selected is not set, then it defaults to the element is not selectable. So I think we should be setting it to false. However, for aria-disabled the default value is the same as if it were set to false, so I think we can just remove the attribute when it's false. I updated the patch with that change.

comment:3 Changed 8 years ago by bill

Presumably you don't need the template.removeAttribute("aria-disabled"); because that attribute isn't there to begin with? Even when you switch from one month to another I thought it would start from scratch, but please check.

Also, please update the tests (probably Calendar_a11y.html) to check these roles. Similar to how Dialog_a11y.html does it.

Last edited 8 years ago by bill (previous) (diff)

comment:4 Changed 8 years ago by Katie Vance

I tested it out and we must remove "aria-disabled", otherwise it will still be there if a user enables them again. I will add test cases to the patch.

comment:5 Changed 8 years ago by Katie Vance

Update patch to include robot test cases.

comment:6 Changed 8 years ago by bill

Milestone: tbd1.7
Summary: dijit.Calendar - No auditive indication for selected and disabled daysCalendar: No auditive indication for selected and disabled days

Looks good to me, I'll check this in.

comment:7 Changed 8 years ago by bill

Actually, the regression test fails on IE8.

comment:8 Changed 8 years ago by Katie Vance

Test case has been fixed

Changed 8 years ago by Katie Vance

Attachment: 13722.patch added

comment:9 Changed 8 years ago by Katie Vance

I added the case for aria-disabled to be false. It's valid for a disabled element to have it as false, however, it will never likely be that way since the code removes it instead of setting it to false.

comment:10 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

In [26376]:

Calendar fixes so JAWS announces selected and disabled days, thanks Katie, fixes #13722 !strict.

comment:11 Changed 8 years ago by bill

Resolution: fixed
Status: closedreopened

This isn't working on IE6, Calendar_a11y.html fails with:

GROUP "aria" has 1 test to run
_AssertFailure: [object Error]: assertEqual() failed: expected false but got false with hint: aria-selected should be false at startup

comment:12 Changed 8 years ago by Adam Peller

moved to 1.7.1 for consideration. Please move to 1.8 as appropriate.

comment:13 Changed 8 years ago by Adam Peller

Milestone: 1.71.7.1

actually moving to 1.7.1

comment:14 Changed 8 years ago by bill

Milestone: 1.7.11.8

comment:15 Changed 8 years ago by bill

Resolution: fixed
Status: reopenedclosed

In [26952]:

So-called "boolean" aria attributes aria-selected, aria-pressed, aria-checked, aria-disabled etc. should actually be strings of "true" or "false", rather than boolean values, as per spec at http://www.w3.org/TR/wai-aria/appendices#typemapping.

Fixes #13722 !strict.

Note: See TracTickets for help on using tickets.