Opened 8 years ago

Closed 8 years ago

#13704 closed defect (fixed)

loader.xdomin test failures (IE6)

Reported by: bill Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: Loader Version: 1.6.1
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

From running dojo/tests/runTests.html on IE6 I get failures in:

  • xdomin-sync-1
  • xdomin-sync-2
  • xdomin-async-1
  • xdomin-async-2
 GROUP "xdomain" has 1 test to run 
    _AssertFailure: [object Error]: assertEqual() failed:  expected true but got false with hint: failed at id=18  [object Error]
     ERROR IN:  function(t){ //console.log(xdomainExecSequence.join(";")); for(var i= 0; i<xdomainLog.length; i+= 2){ t.is(true, xdomainLog[i+1], "failed at id="+xdomainLog[i]); } t.is(expectedSequence, xdomainExecSequence.join(";")); t.is("stepOnLocal1", dojo.tests._base.loader.xdomain.local1); t.is("stepOnLocal1", dojo.getObject("dojo.tests._base.loader.xdomain.local1")); t.is("stepOnLocal1", dojo.require("dojo.tests._base.loader.xdomain.local1")); t.is("stepOnLocal1", require("dojo/tests/_base/loader/xdomain/local1")); t.is("stepOn1SteppedOn", dojo.tests._base.loader.xdomain.local1SteppedOn); t.is("stepOn1SteppedOn", dojo.getObject("dojo.tests._base.loader.xdomain.local1SteppedOn")); t.is("stepOn1SteppedOn", dojo.require("dojo.tests._base.loader.xdomain.local1SteppedOn")); t.is("stepOn1SteppedOn", require("dojo/tests/_base/loader/xdomain/local1SteppedOn")); t.is("local1NotSteppedOn", dojo.tests._base.loader.xdomain.local1NotSteppedOn.status); t.is("local1NotSteppedOn", dojo.getObject("dojo.tests._base.loader.xdomain.local1NotSteppedOn.status")); t.is("local1NotSteppedOn", dojo.require("dojo.tests._base.loader.xdomain.local1NotSteppedOn").status); t.is("local1NotSteppedOn", require("dojo/tests/_base/loader/xdomain/local1NotSteppedOn").status); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", dojo.tests._base.loader.xdomain["local1-dep"].status); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-dep.status")); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", dojo.require("dojo.tests._base.loader.xdomain.local1-dep").status); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", require("dojo/tests/_base/loader/xdomain/local1-dep").status); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", dojo.tests._base.loader.xdomain["local1-runtimeDependent1"].status); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-runtimeDependent1.status")); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", dojo.require("dojo.tests._base.loader.xdomain.local1-runtimeDependent1").status); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", require("dojo/tests/_base/loader/xdomain/local1-runtimeDependent1").status); t.is("ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-runtimeDependent").status); t.is(undefined, dojo.tests._base.loader.xdomain["local1-runtimeDependent2"]); t.is(undefined, dojo.getObject("dojo.tests._base.loader.xdomain.local1-runtimeDependent2")); try{ require("dojo/tests/_base/loader/xdomain/local1/runtimeDependent2"); t.is(1, 0); }catch(e){ t.is(1, 1); } t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", dojo.tests._base.loader.xdomain["local1-browser"].status); t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-browser.status")); t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", dojo.require("dojo.tests._base.loader.xdomain.local1-browser").status); t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", require("dojo/tests/_base/loader/xdomain/local1-browser").status); t.isNot(undefined, dojo.cookie); t.is(dojo.cookie, dojo.getObject("dojo.cookie")); t.is(dojo.cookie, require("dojo/cookie")); if(dohArgs.variation!=1){ t.isNot(undefined, dojo.hash); t.is(dojo.hash, dojo.getObject("dojo.hash")); t.is(dojo.hash, require("dojo/hash")); } } FAILED test: ../../dojo/tests/_base/loader/xdomain/xdomain.html::xdomain::undefined 0 ms PASSED test: ../../dojo/tests/_base/loader/xdomain/xdomain.html 1125 ms ----------------------------------



-------------------------- GROUP "tests._base.loader.xdomin-sync-2" has 1 test to run 1 tests to run in 1 groups

 ------------------------------------------------------------ GROUP "xdomain" has 1 test to run 

    _AssertFailure: [object Error]: assertEqual() failed:  expected true but got false with hint: failed at id=19  [object Error]  

   ERROR IN:  function(t){ //console.log(xdomainExecSequence.join(";")); for(var i= 0; i<xdomainLog.length; i+= 2){ t.is(true, xdomainLog[i+1], "failed at id="+xdomainLog[i]); } t.is(expectedSequence, xdomainExecSequence.join(";")); t.is("stepOnLocal1", dojo.tests._base.loader.xdomain.local1); t.is("stepOnLocal1", dojo.getObject("dojo.tests._base.loader.xdomain.local1")); t.is("stepOnLocal1", dojo.require("dojo.tests._base.loader.xdomain.local1")); t.is("stepOnLocal1", require("dojo/tests/_base/loader/xdomain/local1")); t.is("stepOn1SteppedOn", dojo.tests._base.loader.xdomain.local1SteppedOn); t.is("stepOn1SteppedOn", dojo.getObject("dojo.tests._base.loader.xdomain.local1SteppedOn")); t.is("stepOn1SteppedOn", dojo.require("dojo.tests._base.loader.xdomain.local1SteppedOn")); t.is("stepOn1SteppedOn", require("dojo/tests/_base/loader/xdomain/local1SteppedOn")); t.is("local1NotSteppedOn", dojo.tests._base.loader.xdomain.local1NotSteppedOn.status); t.is("local1NotSteppedOn", dojo.getObject("dojo.tests._base.loader.xdomain.local1NotSteppedOn.status")); t.is("local1NotSteppedOn", dojo.require("dojo.tests._base.loader.xdomain.local1NotSteppedOn").status); t.is("local1NotSteppedOn", require("dojo/tests/_base/loader/xdomain/local1NotSteppedOn").status); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", dojo.tests._base.loader.xdomain["local1-dep"].status); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-dep.status")); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", dojo.require("dojo.tests._base.loader.xdomain.local1-dep").status); t.is("dojo.tests._base.loader.xdomain.local1-dep-ok", require("dojo/tests/_base/loader/xdomain/local1-dep").status); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", dojo.tests._base.loader.xdomain["local1-runtimeDependent1"].status); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-runtimeDependent1.status")); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", dojo.require("dojo.tests._base.loader.xdomain.local1-runtimeDependent1").status); t.is("dojo.tests._base.loader.xdomain.local1-runtimeDependent1-ok", require("dojo/tests/_base/loader/xdomain/local1-runtimeDependent1").status); t.is("ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-runtimeDependent").status); t.is(undefined, dojo.tests._base.loader.xdomain["local1-runtimeDependent2"]); t.is(undefined, dojo.getObject("dojo.tests._base.loader.xdomain.local1-runtimeDependent2")); try{ require("dojo/tests/_base/loader/xdomain/local1/runtimeDependent2"); t.is(1, 0); }catch(e){ t.is(1, 1); } t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", dojo.tests._base.loader.xdomain["local1-browser"].status); t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", dojo.getObject("dojo.tests._base.loader.xdomain.local1-browser.status")); t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", dojo.require("dojo.tests._base.loader.xdomain.local1-browser").status); t.is("dojo.tests._base.loader.xdomain.local1-browser-ok", require("dojo/tests/_base/loader/xdomain/local1-browser").status); t.isNot(undefined, dojo.cookie); t.is(dojo.cookie, dojo.getObject("dojo.cookie")); t.is(dojo.cookie, require("dojo/cookie")); if(dohArgs.variation!=1){ t.isNot(undefined, dojo.hash); t.is(dojo.hash, dojo.getObject("dojo.hash")); t.is(dojo.hash, require("dojo/hash")); } } FAILED test: ../../dojo/tests/_base/loader/xdomain/xdomain.html::xdomain::undefined 0 ms PASSED test: ../../dojo/tests/_base/loader/xdomain/xdomain.html 1125 ms ------------------------------------------------------------

Change History (3)

comment:1 Changed 8 years ago by bill

Keywords: dohfail added

comment:2 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

this is a duplicate of #13409

Note: See TracTickets for help on using tickets.