Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#13697 closed defect (fixed)

shift+enter may throw error in Editor

Reported by: liucougar Owned by: liucougar
Priority: high Milestone: 1.7
Component: Editor Version: 1.6.1
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

when the selection starts at the beginning of a block element

Change History (8)

comment:1 Changed 8 years ago by liucougar

Owner: set to liucougar
Resolution: fixed
Status: newclosed

In [26217]:

fixes #13697: take into account that a block element may be empty when inserting shift+enter <br>

also fixed a range.deleteContents() issue in IE: it would leave the range invalid in some cases

!strict

comment:2 Changed 8 years ago by bill

Component: GeneralEditor

Thanks. Can you add a test case for this to the EnterKeyHandling.html robot test?

comment:3 Changed 8 years ago by liucougar

In [26244]:

refs #13697: added a robot test for this

comment:4 Changed 8 years ago by bill

Keywords: dohfail added
Resolution: fixed
Status: closedreopened

That robot test is failing intermittently for me (tested on IE8).

comment:5 Changed 8 years ago by liucougar

In [26663]:

refs #13697: give it more time after keypress before asking for the editor content in EnterKeyHandling test

Last edited 8 years ago by bill (previous) (diff)

comment:6 Changed 8 years ago by Jared Jurkiewicz

Resolution: fixed
Status: reopenedclosed

Assuming Liu's change fixed issue, so marking fixed.

comment:7 Changed 7 years ago by DJ Mountney

This is still an issue on IE8, and IE7 when blockNodeforEnter='BR'.

<p>ab</p>

If you put the cursor after b, hit ctrl-enter, then backspace, then ctrl-enter again, the browser crashes.

Or if you just enter some text, then use fontchoice to change it's format, then hit ctrl-enter twice at the end of it.

Last edited 7 years ago by DJ Mountney (previous) (diff)

comment:8 Changed 7 years ago by bill

I can reproduce a browser crash on IE8 in dijit/tests/editor/EnterKeyHandling.html, by setting the first editor to <p>ab</p>, putting the caret after "b", and then typing ctrl-enter, backspace, ctrl-enter, ctrl-enter. Likewise with shift-enter.

Seems like a different bug than this one though since this is about being at the beginning of a block element. I filed #16832 to track it.

Note: See TracTickets for help on using tickets.