Opened 8 years ago

Closed 8 years ago

#13696 closed defect (wontfix)

Initial space in dijit._editor.RichText in webkit browser

Reported by: nuda7 Owned by:
Priority: high Milestone: tbd
Component: Editor Version: 1.6.1
Keywords: editor richtext space webkit Cc: Jared Jurkiewicz
Blocked By: Blocking:

Description (last modified by bill)

There is in dijit/_editor/RichText.js on line 1487:

html = " ";

Comment is

// Use   to avoid webkit problems where editor is disabled until the user clicks it

I think that initial space is not usefull - editor in webkit browsers(chrome, safari) is still disabled until I click it. So that space dont have to be there. I think it should be removed, so it will be: html="";. I tested it, and there is no difference, only there is no initial space, when content of editor is empty.

Change History (5)

comment:1 Changed 8 years ago by Adam Peller

Cc: Jared Jurkiewicz added

IIRC, it had something to do with the area not being clickable unless there's a space in it

comment:2 Changed 8 years ago by Jared Jurkiewicz

Resolution: invalid
Status: newclosed

That space does have a purpose as Peller noted. without it, you cannot click inside the editor to set a cursor. Invalid bug, closing.

comment:3 Changed 8 years ago by bill

Description: modified (diff)
Resolution: invalid
Status: closedreopened

I tried removing that code, and then clicking inside the editor (running test_Editor.html) on Safari 5.1/mac and Chrome 14/win. It works for me.

Did you guys remove the code and find that you couldn't activate the editor? If so, which browser/OS combo?

Also note that the comment in the source doesn't match what peller said.

comment:4 Changed 8 years ago by liucougar

IIRC the problem is with Firefox

comment:5 Changed 8 years ago by Jared Jurkiewicz

Resolution: wontfix
Status: reopenedclosed

The problem is specific to firefox, the space is required, or focus doesn't work. To keep browsers closer to consistent in output, the space is generally used on all browsers. Closing this as wontfix since it is intentionally there.

Note: See TracTickets for help on using tickets.