Opened 8 years ago

Closed 8 years ago

#13686 closed defect (fixed)

mobileGauges demo doesn't work after build

Reported by: Ming Zhe Huang Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

Please compare the pre-build and post-build versions.

There's no error in browser debug console (FF and Chrome).

Change History (13)

comment:1 Changed 8 years ago by bill

The nested require() syntax in src.js is weird, but seems like it should still work:

require(["dojo/domReady!"], function(){
	require([
	 "dojox/mobile",
	 "dojox/mobile/parser",
	 "dojox/mobile/compat",
	 "dojox/mobile/Button",

comment:2 Changed 8 years ago by bill

Milestone: tbd1.7

... except that the dojo/domReady! isn't firing at all.

comment:3 Changed 8 years ago by Rawld Gill

Likely fixed as of [26215]; checked src and built version and it seems OK. Please recheck and verify that this is fixed.

comment:4 Changed 8 years ago by bill

Hmm, I'm trying the built version against FF5/mac and it's still failing for me. (The source version is working OK for me.)

comment:5 Changed 8 years ago by Douglas Hays

I'm trying the 2 links above and don't see a difference. Is this still broken?

comment:6 Changed 8 years ago by bill

Last time it fails for me from archive.dojotoolkit.org is http://archive.dojotoolkit.org/dojo-2011-08-17/dojotoolkit/demos/mobileGauges/demo.html but not sure what changed between 8/17 and 8/18, I'll trace it further to see if the underlying bug is really fixed.

Last edited 8 years ago by bill (previous) (diff)

comment:7 Changed 8 years ago by bill

On my machine, even with the latest code ([26331]), when I do a build like:

./build.sh copyTests=true mini=false action=clean,release profile=standard cssOptimize=comments.keepLines cssImportIgnore=../dijit.css releaseDir=../../../release optimize=shrinksafe

and then access it like:

http://localhost/release/dojo/demos/mobileGauges/demo.html

I still get failures on both FF5/mac and safari/mac, specifically (from FF5/mac):

"NetworkError: 404 Not Found - http://localhost/release/dojo/dojo/demos/mobileGauges/src/VistaGauge.js"
VistaGauge.js
"NetworkError: 404 Not Found - http://localhost/release/dojo/dojo/demos/mobileGauges/src/PlasticGauge.js"
PlasticGauge.js
"NetworkError: 404 Not Found - http://localhost/release/dojo/dojo/demos/mobileGauges/src/XpGauge.js"

(Those files do exist.)

comment:8 in reply to:  7 Changed 8 years ago by Rawld Gill

Replying to bill:

On my machine, even with the latest code ([26331]), when I do a build like:

./build.sh copyTests=true mini=false action=clean,release profile=standard cssOptimize=comments.keepLines cssImportIgnore=../dijit.css releaseDir=../../../release optimize=shrinksafe

and then access it like:

http://localhost/release/dojo/demos/mobileGauges/demo.html

I still get failures

[snip]

hmmm, profile=standard should not even build the demos, so I don't understand how a built mobileGauges/demo.html even exists, let alone fails.

I just built with profile=demos-all with all other parameters mentioned above unchanged and mobileGauges/demo.html appears to work OK.

As I don't have a mac env, could someone give a demos-all build a try?

comment:9 Changed 8 years ago by bill

I forgot to mention that I copied (actually, symbolic linked) the demos/ folder from the src/ tree to the build tree, so it's an unbuilt mobileGauges running against a built dojo.js. Then the problem reproduces for me on both mac and windows (IE8 and FF). How about you?

comment:10 Changed 8 years ago by bill

Hmm, actually now that I look at it, it just seems to be a path problem, that it's searching for a release/dojo/dojo/demos directory that doesn't exist (it should be looking for release/dojo/demos).

Not sure why, since I made demos/ a sibling of the dojo/ and dijit/ directories, same as in the source tree.

Last edited 8 years ago by bill (previous) (diff)

comment:11 in reply to:  10 Changed 8 years ago by Rawld Gill

Replying to bill:

Hmm, actually now that I look at it, it just seems to be a path problem, that it's searching for a release/dojo/dojo/demos directory that doesn't exist (it should be looking for release/dojo/demos).

Not sure why, since I made demos/ a sibling of the dojo/ and dijit/ directories, same as in the source tree.

I'd have to do some poking around to be sure, but...the builder rolls in a configuration at the bottom of dojo.js. So a build consequent to the standard profile will *not* have a package configuration for the demo package whereas [e.g.] a demos-all profile build will have a package config for the demo package.

comment:12 Changed 8 years ago by Douglas Hays

demos-all build seems to work well

comment:13 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

OK, so it's just a configuration problem on my end then, I'll close this ticket.

Note: See TracTickets for help on using tickets.