Opened 8 years ago

Closed 8 years ago

#13681 closed defect (fixed)

Dojo build problem with 1.7.0dev (23930)

Reported by: _korso_ Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have some problems with dojo 1.7 build system. I use trunk version from http://svn.dojotoolkit.org/src/view/anon/all/trunk. At the moment build system is not so crucial, because I'm starting to work on dojo 1.7.0 project and have couple of months to finish it. So I guess in that time final 1.7 version will be released.

First, I am trying to build very basic script, to figure out concepts behind build system ... after that I'll try some complex build.

This is my starting point tutorial http://dojotoolkit.org/documentation/tutorials/1.6/build.

Here is my project a layout:

/dojotest -> web server root
    /test.html -> this file is in attachement
/dojo-1.7.0 -> trunk version
    /dojo
    ...
    /util

I have confugured in apache VirtualHost directive to point on something like this:

Alias /dojo/ "/Users/pera/workspace/dojo-1.7.0/"

Page is ok, very simple and it works. Here is a cmd for building simple html page.

pera ~/workspace/dojo-1.7.0/util/buildscripts$ ./build.sh action=release htmlFiles=/Users/pera/workspace/dojotest/test.html releaseDir=/Users/pera/workspace/ 

And error/output from previous build cmd is:

running under rhino
js: "<eval'ed string>#1(Function)#1(eval)", line 117: uncaught JavaScript runtime exception: ReferenceError: "processHtmlFiles" is not defined.
        at <eval'ed string>#1(Function)#1(eval):117
        at <eval'ed string>#1(Function)#1(eval):103
        at <eval'ed string>#1(Function)#1(eval):84

That is all. I posted on dojo forums, looking myself to solve this, but nothing ...

Attachments (1)

test.html (545 bytes) - added by _korso_ 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by _korso_

Attachment: test.html added

comment:1 Changed 8 years ago by _korso_

I can confirm that alias directive is not a problem. I removed it from config (however I never doubted that it was a problem - but I want to be sure).

I change dirs structure:

/dojotest
   /dojo
   /dojox
   /dijit
   /util
   test.html
Last edited 8 years ago by _korso_ (previous) (diff)

comment:2 Changed 8 years ago by Chris Mitchell

Also seeing this from another user...

I'm running the build from the command line out of the utils/buildscript directory. I'm not using chiron. I'm specifying action=release and htmlFiles=myhtml.html

I made my html file trivial. It basically has

<script type="text/javascript" src="/dojo-release-1.7.0b5/dojo/dojo.js" djConfig="parseOnLoad: true"></script>

<script language="JavaScript" type="text/javascript">
dojo.require("dojox.mobile.parser");
dojo.require("dojox.mobile");
dojo.require("dojox.mobile.ScrollableView");
dojo.require("dojox.mobile.IconContainer");
dojo.requireIf(!dojo.isWebKit, "dojox.mobile.compat");
</script>

and a simple <ul>.

BTW, I did manage to do a build by creating a profile based on mobile-all and added stuff that was missing. Just couldn't get it to work by pointing to my HTML and having the build system tell me what I needed.

comment:3 Changed 8 years ago by Chris Mitchell

We're also seeing this in one of our projects, Trying to get more info.

comment:4 Changed 8 years ago by Chris Mitchell

The error messages are a bit useless.

comment:5 Changed 8 years ago by Chris Mitchell

Seeing this issue on 1.7b5

comment:6 Changed 8 years ago by Chris Mitchell

~/RTC3/MAPWorkspace/sample-mysurance/build/dojo/util/buildscripts> ./build.sh profile=mysurance action=clean,release stripConsole=all layerOptimize=shrinksafe optimize=shrinksafe releaseDir=../../../ cssOptimize=comments releaseName=dojo_optimized copyTests=false running under rhino info(107) Package Version: package: dojox; version: 1.7.0dev info(107) Package Version: package: dijit; version: 1.7.0b5 warn(209) Missing or empty package.json. filename: /home/nagy/RTC3/MAPWorkspace/sample-mysurance/build/style/package.json info(107) Package Version: package: dojo; version: 1.7.0b5 discovering resources... starting reading resources... starting processing raw resource content... starting tokenizing resource... starting processing resource tokens... starting parsing resource... js: "<eval'ed string>#1(Function)#1(eval)", line 51: uncaught JavaScript? runtime exception: TypeError?: Cannot call method "map" of null

at <eval'ed string>#1(Function)#1(eval):51 at <eval'ed string>#1(Function)#1(eval):105 at <eval'ed string>#1(Function)#1(eval):138 at <eval'ed string>#1(Function)#1(eval):162 at <eval'ed string>#1(Function)#1(eval):257 at <eval'ed string>#1(Function)#1(eval):305 at <eval'ed string>#1(Function)#1(eval):264 at <eval'ed string>#1(Function)#1(eval):264 at <eval'ed string>#1(Function)#1(eval):235 (doBuild) at <eval'ed string>#1(Function)#1(eval):270 at <eval'ed string>#1(Function)#1(eval):84

Note: this project has a custom profile that was based on 1.7b1... maybe it's due to missing base modules that have since been added to the mobile or base profiles?

comment:7 Changed 8 years ago by Chris Mitchell

dev is reporting they seem to be having this error when profile name is > 8 chars. they've tried 2 diff profiles with long names,both failed, then shortened them and appears to work.

comment:8 Changed 8 years ago by Chris Mitchell

more info from the developer... I *think* that my assertion about layer length was wrong (thankfully). I believe that the build doesn't complain if it can't find a profile -- it just tries to build something, but never tells you that it can't find the profile. So I think that it (1) didn't like something in the profile that I was trying to use, which resulted in the explosion and (2) couldn't find the profile the other times, but wasn't saying anything. You can make up a random profile name, do a 'build.sh profile=fdsaf' and it will build *something* without complaining 12:56:38 PM: wnagy@… - William A Nagy/Watson?/IBM: so when it looked like it was working, it wasn't actually reading the profile 12:57:13 PM: wnagy@… - William A Nagy/Watson?/IBM: I wanted to try to find a 'verbose' option so that it would tell me exactly what it's doing, but I have been unsuccessful 1:05:01 PM: wnagy@… - William A Nagy/Watson?/IBM: (it looks like the logging is already set to 'trace' level, so I guess I'm just out of luck)

comment:9 Changed 8 years ago by Rawld Gill

Status: newassigned
Version: 1.7.0b1

comment:10 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

In [26651]:

fixed several problems with port of htmlFiles build switch from 1.6; fixes #13681; !strict

Note: See TracTickets for help on using tickets.