Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13671 closed defect (duplicate)

datagrid sorting keeps incorrect selection

Reported by: tanneman Owned by: Evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

steps to reproduce

expected

  • The selection stays on the row that shows the item first selected (or selection is cleared)

actual

  • The selection stays on the row index

Change History (4)

comment:1 Changed 8 years ago by tanneman

The selection also persists when another store is set. (seems to me that the _clearData may clear the selection as well?)

comment:2 Changed 8 years ago by Evan

Owner: changed from evan to Evan

comment:3 Changed 8 years ago by Evan

Resolution: duplicate
Status: newclosed

Duplicate with #7304 which provided a fix:

"The selection persistence feature is still limited with

  1. Key precondition - Store Identifier(id) is required since id is used for differentiating row items.
  2. Known issue - might not be accurate if some unloaded rows are selected by range(e.g.SHIFT + click)

Usage - To turn on this, please set 'keepSelection' attribute to true, e.g.
<div dojoType="dojox.grid.DataGrid??" keepSelection = true .../> or
<div dojoType="dojox.grid.TreeGrid??" keepSelection = true .../> or
<div dojoType="dojox.grid.LazyTreeGrid??" keepSelection = true .../>"

comment:4 Changed 8 years ago by Evan

Milestone: tbd1.7
Note: See TracTickets for help on using tickets.