Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1367 closed defect (fixed)

uri/__package.js has incorrect dojo.kwCompoundRequire

Reported by: guest Owned by: dylan
Priority: high Milestone:
Component: General Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

uri/__package__.js has the following code:

dojo.kwCompoundRequire({
	common: ["dojo.uri.Uri", false, false]
});

This should be:

dojo.kwCompoundRequire({
	common: [["dojo.uri.Uri", false, false]]
});

which is equivalent to just plain old:

dojo.kwCompoundRequire({
	common: ["dojo.uri.Uri"]
});

Change History (4)

comment:1 Changed 13 years ago by guest

Ditto for logging/__package__.js which contains:

dojo.kwCompoundRequire({
	common: ["dojo.logging.Logger", false, false],
	rhino: ["dojo.logging.RhinoLogger"]
});

and rpc/__package__.js which contains:

dojo.kwCompoundRequire({
	common: ["dojo.rpc.JsonService", false, false]
});

comment:2 Changed 13 years ago by dylan

Milestone: 0.4
Owner: changed from anonymous to dylan
Status: newassigned

comment:3 Changed 13 years ago by dylan

Resolution: fixed
Status: assignedclosed

(In [5438]) incorrect dojo.kwCompoundRequire statements, fixes #1367

comment:4 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.