Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13666 closed defect (fixed)

Axis label disappearing when using a theme and setting titleOrientation: 'away'

Reported by: dbellettini Owned by: cjolif
Priority: high Milestone: 1.8
Component: Charting Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

See the attachment

Attachments (1)

dojotest.html (2.0 KB) - added by dbellettini 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by dbellettini

Attachment: dojotest.html added

comment:1 Changed 8 years ago by dbellettini

I made a mistake, the component is Charting

comment:2 Changed 8 years ago by bill

Component: GeneralCharting
Owner: set to Eugene Lazutkin

comment:3 Changed 8 years ago by dbellettini

Affects Firefox 5.0.1
Affects Chromium 12.0.742.112
Does not affect Internet Explorer 9

comment:4 Changed 8 years ago by cjolif

Milestone: tbd1.8
Owner: changed from Eugene Lazutkin to cjolif
Status: newassigned

A workaround is to set htmlLabels: false on your axis.

Version 0, edited 8 years ago by cjolif (next)

comment:5 Changed 8 years ago by cjolif

The origin of the problem is that the font for the title is not found on the Claro theme and that an exception occurs. The way title font is defined in themes is not documented. They are strangely not defined in theme.axis.titleFont or theme.axis.title.font but theme.axis.tick.titleFont and thus not inherited from default theme to Claro. Part of the fix will consist in documenting and correctly locating title font in axis.title.font.

comment:6 Changed 8 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [27014]:

fixes #13666. Document title properties on axis and theme. On theme make sure they are correctly avaible in axis.title not as properties of axis.tick. That fixes issue with title not appearing with inherited themes. Also some small clean ups. !strict.

comment:7 Changed 8 years ago by cjolif

In [27040]:

now that we do not do anymore a blind try{}catch{} in Axis, having an axis where it does not make sense (i.e. Pie) make it crash. This fix is preventing axis to be used for Pie. Refs #13666. !strict.

Note: See TracTickets for help on using tickets.