Opened 8 years ago

Closed 8 years ago

#13650 closed defect (fixed)

tests.loader.requirejs-urlfetch-sync test failure (IE8)

Reported by: bill Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: Loader Version: 1.6.1
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

TypeError: 'require.modules.one.node.src' is null or not an object     ERROR IN: 		 function urlfetch(t){
                        //First confirm there is only one script tag for each
                        //module:
                        var scripts = document.getElementsByTagName("script"),
                            i, counts = {}, url, props, something;
                        for (var i = scripts.length - 1; i > -1; i--) {
                            url = scripts[i].src;
                            if (url) {
                                if (!(url in counts)) {
                                    counts[url] = 0;
                                }
                                counts[url] += 1;
                            }
                        }

						if(require.modules){
							// the dojo loader; looking at internal structures for this test
							t.is(2, counts[require.modules["one"].node.src]);
							t.is(2, counts[require.modules["three"].node.src]);							
						}else{
							// requirejs impl
						    for (prop in counts) {
								t.is(1, counts[prop]);
	                        }
						}

                        t.is("one", one.name);
                        t.is("one", two.oneName);
                        t.is("two", two.name);
                        t.is("three", three.name);
                        t.is("three", four.threeName);
                        t.is("four", four.name);
                    } FAILED test: ../../dojo/tests/_base/loader/requirejs/urlfetch/urlfetch.html::urlfetch::urlfetch 0 ms

Change History (3)

comment:1 Changed 8 years ago by bill

Keywords: dohfail added

comment:2 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

duplicate of #13410; now fixed

Note: See TracTickets for help on using tickets.