Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1365 closed defect (wontfix)

dojo.hostenv.getModulePrefix() on unregistered module returns module name

Reported by: guest Owned by: James Burke
Priority: high Milestone:
Component: Loader Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

This based on an SVN checkout 29th Aug 06.

If you call the dojo.hostenv.getModulePrefix() method on a module that hasn't been registered (using dojo.registerModulePath()), the return value is the the module name that was passed in. Perhaps this is intended behaviour, but if so then it's not really very helpful. I'd have thought a 'module not registered' error (or similar) would be more useful.

Change History (4)

comment:1 Changed 13 years ago by dylan

Component: GeneralPackageSystem
Milestone: 0.4
Owner: changed from anonymous to alex
Version: 0.20.3

comment:2 Changed 13 years ago by James Burke

Owner: changed from alex to James Burke

Stealing io and package bugs from Alex. Holler if you want it back.

comment:3 Changed 13 years ago by James Burke

Resolution: wontfix
Status: newclosed

The module loading code depends on this behavior, so I am not going to fix it. If you want to to check for an "error" or if there is no module prefix, just check to see if the return value matches the value passed in to getModulePrefix().

comment:4 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.