Opened 8 years ago

Closed 8 years ago

#13640 closed defect (wontfix)

TitlePane: cannot scroll contained <div> by dragging scrollbar handle

Reported by: sherzy Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.0
Keywords: IE, Internet Explorer Cc:
Blocked By: Blocking:

Description

When a div is inside a dijit.TitlePane? and set to scroll (overflow:auto) the scrollbar is not draggable. You can scroll by click on the arrows, or using the mouse wheel, but not dragging the bar, as many people are used to doing. Bug appears only in Internet Explorer (I tested in versions 7, 8 and 9), works fine in Firefox and Chrome.

Test page attached

Attachments (1)

bug.html (4.9 KB) - added by sherzy 8 years ago.
IE scolling bug

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by sherzy

Attachment: bug.html added

IE scolling bug

comment:1 Changed 8 years ago by bill

Summary: Scroll bar not draggable in IE when in Title PaneTitlePane: cannot scroll contained <div> by dragging scrollbar handle

comment:2 Changed 8 years ago by bill

Resolution: wontfix
Status: newclosed

I can reproduce it on IE6 although it worked for me on IE8... in any case it's a really weird bug.

Note also that (at least for me) the scrollbar is draggable after you once click somewhere else on the page.

So I added this workaround code to your test case that solved the problem for me, by simulating a click on the page:

function fireEvt(name){
	var rect = dojo.query(".dijitTitlePaneContentInner")[0];
	if(!document.createEvent){
		rect.fireEvent('on' + name);
	}else{
		var clickEvent = document.createEvent("MouseEvent");
		clickEvent.initMouseEvent(name, true, true, window, 0,0,0,0,0,0,0,0,0,0,null);
		rect.dispatchEvent(clickEvent);
	}
}
dojo.ready(function(){
	setTimeout(function(){
		fireEvt("mousedown");
	}, 10);

});

Since this is a corner case problem I don't think it's worth adding that code into TitlePane itself. Please add it to your app, or something similar, and hopefully that will fix your problem. Also, if you happen to figure out a less hacky way of resolving this, let us know.

Note: See TracTickets for help on using tickets.