Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1364 closed defect (invalid)

Menu2 occasionally not visible

Reported by: bbellomo@… Owned by: bill
Priority: high Milestone: 0.9
Component: Widgets Version: 0.3
Keywords: menu2 Cc: bbellomo@…
Blocked By: Blocking:

Description

In rare circumstances, using IE7 RC1 and beta3, I have seen a page with a menu simply not be visible after the page loads. Reloading the page (refresh button) fixes the problem. I am not sure if this happens in other browsers (I have not seen it, but it is rare).

This makes it very hard to put the menu in production on heavily used pages.

I will try to debug and update this ticket, but I wanted to submit it in case anyone finds something similar, or has time to work on it.

Change History (5)

comment:1 Changed 13 years ago by dylan

Milestone: 0.40.5
Version: 0.40.3

pushing to 0.5, unless there is an obvious cause.

comment:2 Changed 13 years ago by dylan

Component: GeneralWidgets
Owner: changed from anonymous to bill

comment:3 Changed 13 years ago by bill

Cc: bbellomo@… added

I changed all the menu code to use tables rather than divs with javascript sizing. Can you try again to see if the problem is still occurring?

comment:4 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

no update in >6 months. Please re-open if you can reproduce. Thanks

comment:5 Changed 12 years ago by guest

I observed similar behavior some time ago, when trying to run dojo 0.4.2 samples directly from the site. The page was loading slow, and several times it did not load correctly at all, but worked OK after I hit the refresh button.

Apparently, that was caused by those pages using non-packed version of dojo, thus loading a lot of small files.

Note: See TracTickets for help on using tickets.