Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#13636 closed defect (fixed)

[regression] tooltips misplaced in Firefox in RTL

Reported by: Douglas Hays Owned by: bill
Priority: high Milestone: 1.6.2
Component: Dijit Version: 1.6.1
Keywords: Cc: susheel_ahuja
Blocked By: Blocking:

Description

Starting with [23866], tooltips for Firefox in RTL seem to be hugely misplaced. This affects 1.6 and 1.7. Run
dijit/tests/form/test_validate.html?dir=rtl
in Firefox 3.6 and enter something invalid in the elevation field.

Change History (7)

comment:1 Changed 8 years ago by Douglas Hays

Cc: susheel_ahuja added

comment:2 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

In [26167]:

Fix placement of popups on firefox in RTL mode, fixes #13636 !strict.

comment:3 Changed 8 years ago by bill

Good catch, looks like firefox has issues setting style="right: 123" if you don't explicitly set left: auto. I checked in a workaround.

Although IE is working perfectly, chrome / safari / FF misalign each drop down by about 20px. I thought it was the scrollbar being on the right instead of the left, but I checked and the problem is also happening on opera on a real RTL machine, were the scrollbar is on the left. So, better than before but still not perfect.

comment:4 Changed 7 years ago by bill

In [27036]:

Backport [26167] to 1.6 branch, fixing Tooltip RTL placement issue, refs #13636 !strict

comment:5 Changed 7 years ago by bill

Milestone: 1.71.6.2

comment:6 in reply to:  5 Changed 7 years ago by smaheshbhat

Bill,

For this any workaround possible in dojo 1.6 ? Thanks, Mahesh

comment:7 Changed 7 years ago by bill

I can't think of a workaround, I'd suggest just getting the latest code from the 1.6 branch, or at least place.js.

Note: See TracTickets for help on using tickets.