Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13635 closed defect (fixed)

Grid - repeat invoking grid.setStore()/setQuery() will cause inconsistent parameter state

Reported by: evan Owned by: evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.7.0b1
Keywords: grid, setStore, setQuery Cc:
Blocked By: Blocking:

Description

When repeat invoking grid.setStore()/setQuery() with a very short interval, since _refrech() --> fetch(0) will be called internally which means later _pending_requests[0] will be ignored, but the new store or query will be set and this results into an finally inconsistent state.

Change History (2)

comment:1 Changed 8 years ago by evan

Resolution: fixed
Status: newclosed

In [26116]:

Fixes #13635 - ignore and not set store or query when _requestPending(0)

comment:2 Changed 8 years ago by bill

#15162 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.